Bug 875364 - Both 18 Beta TC8 install DVDs are > 4.7 GB
Both 18 Beta TC8 install DVDs are > 4.7 GB
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-10 14:59 EST by Andre Robatino
Modified: 2014-03-16 23:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 02:17:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-11-10 14:59:06 EST
Description of problem:
Fedora-18-Beta-TC8-i386-DVD.iso : 4812963840 bytes (4.81 GB)
Fedora-18-Beta-TC8-x86_64-DVD.iso : 4718592000 bytes (4.71859 GB)

The official size limit is 4700000000 bytes = 4.7 GB. Even with the slightly higher size limits listed at https://en.wikipedia.org/wiki/DVD#Capacity , these will not fit on single-layer DVDs.

Version-Release number of selected component (if applicable):
18 Beta TC8 DVDs
Comment 1 Kamil Páral 2012-11-12 12:52:35 EST
Discussed at 2012-11-12 QA meeting acting as a blocker review meeting. Accepted as a blocker: Violates the following F18 beta release criterion: "The network installation image, DVD image, and live images for release-blocking desktops must meet current size requirements"
Comment 2 Bill Nottingham 2012-11-12 12:58:22 EST
1) kernel-debug is getting into the tree. Fixing in spin-kickstarts.

2) mate is getting pulled in. Unsure why.

3) texlive is being pulled in. Again, unsure why.
Comment 3 Bill Nottingham 2012-11-12 13:02:26 EST
mate:

1) blueman -> mate-polkit, imsettings -> imsettings-mate, firstboot -> mate-window-manager

texlive:

2) eclipse-pydev -> python-ipython-console -> python-matplotlib -> texlive-dvipng-bin
Comment 4 Jaroslav Reznik 2012-11-13 07:06:44 EST
(In reply to comment #3)
> mate:
> 
> 1) blueman -> mate-polkit, imsettings -> imsettings-mate, firstboot ->
> mate-window-manager

Blueman Requires: PolicyKit-authentication-agent and it's satisfied by mate-polkit, same would apply for imsettings and firstboot.

> texlive:
> 
> 2) eclipse-pydev -> python-ipython-console -> python-matplotlib ->
> texlive-dvipng-bin

python-matplotlib has BuildRequires: tex(latex), not sure why it drags textlive as Requires at this seems to be used for html docs generation. CC'ing jnovy.
Comment 5 Jindrich Novy 2012-11-13 09:52:09 EST
(In reply to comment #4)
> > texlive:
> > 
> > 2) eclipse-pydev -> python-ipython-console -> python-matplotlib ->
> > texlive-dvipng-bin
> 
> python-matplotlib has BuildRequires: tex(latex), not sure why it drags
> textlive as Requires at this seems to be used for html docs generation.
> CC'ing jnovy.

There is a circular dependency between python-matplotlib and python-basemap. Maybe the best solution is to move the dependency to python-matplot-gtk subpackage. The dependency for dvipng was added just for matplotlib-python with gtk backend (bug #684836).
Comment 6 Bill Nottingham 2012-11-13 14:44:37 EST
(In reply to comment #4)
> (In reply to comment #3)
> > mate:
> > 
> > 1) blueman -> mate-polkit, imsettings -> imsettings-mate, firstboot ->
> > mate-window-manager
> 
> Blueman Requires: PolicyKit-authentication-agent and it's satisfied by
> mate-polkit, same would apply for imsettings and firstboot.

Right, pungi pulls in *all* providers of something by default, which will pull in the mate implementations as well as all the others. We could exclude these in the kickstart.
Comment 7 Jaroslav Reznik 2012-11-14 08:14:49 EST
Well, kernel-debug was already pulled into TC1. Mate-desktop in TC7. Texlive in TC8. I'm going to report bug for texlive, kernel-debug is already excluded in spin-kickstarts git. Is Mate now part of install DVD - see https://bugzilla.redhat.com/show_bug.cgi?id=873342 ? 

With Mate in, we are 4584374272 for 386 and 4490002432 for x86_64 for TC7. Kernel debug is about 28 MB. So the top offender is texlive.
Comment 8 Kevin Fenzi 2012-11-14 10:39:55 EST
no offense to the hard working MATE folks, but I don't think we want to add it to the DVD in beta test composes. This would be something for f19. 

Note that the only parts of MATE that were pulled in is polkit, due to the way the compose works, we should simply exclude mate-polkit and that should fix that issue. 

Some of the old texlive packages were not blocked in f18, so that might be part at least of what was pulled in.
Comment 9 Jaroslav Reznik 2012-11-14 11:24:59 EST
(In reply to comment #8)
> no offense to the hard working MATE folks, but I don't think we want to add
> it to the DVD in beta test composes. This would be something for f19. 
> 
> Note that the only parts of MATE that were pulled in is polkit, due to the
> way the compose works, we should simply exclude mate-polkit and that should
> fix that issue. 

Up to TC7 only the providers were pulled in, TC7 seems to contain the whole Mate (or at least, mate-desktop is in).

> Some of the old texlive packages were not blocked in f18, so that might be
> part at least of what was pulled in.

This could be the reason for texlive, Jindra is currently taking a look what else could be needed. As an emergency case for Beta we could block offending packages from install DVD (but really as the last resort solution).
Comment 10 Bill Nottingham 2012-11-14 11:47:27 EST
(In reply to comment #9)
> (In reply to comment #8)
> > no offense to the hard working MATE folks, but I don't think we want to add
> > it to the DVD in beta test composes. This would be something for f19. 
> > 
> > Note that the only parts of MATE that were pulled in is polkit, due to the
> > way the compose works, we should simply exclude mate-polkit and that should
> > fix that issue. 
> 
> Up to TC7 only the providers were pulled in, TC7 seems to contain the whole
> Mate (or at least, mate-desktop is in).

Right, cascading dependencies. I think blocking in the kickstart file is the simplest answer here.
Comment 11 Bill Nottingham 2012-11-14 11:50:21 EST
MATE excluded in git rev 11165f6.
Comment 12 Bill Nottingham 2012-11-14 12:02:15 EST
And given bug 875380, flipping to MODIFIED. Please retest with TC9.
Comment 13 Tim Flink 2012-11-14 15:32:55 EST
I did a test compose with the new spin-kickstarts. The DVD is 4.3G on disk. I can push it somewhere public if somebody wants it but otherwise, I'll wait for a new anaconda build before doing another smoke test
Comment 14 Jindrich Novy 2012-11-15 13:16:44 EST
The dependency spree caused by dvipng (and texlive) should be gone since texlive-2012-8.20121115_r28267.fc18. I will release F18 update as soon as it's built.
Comment 15 Fedora Update System 2012-11-16 02:04:07 EST
texlive-2012-8.20121115_r28267.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/texlive-2012-8.20121115_r28267.fc18
Comment 16 Andre Robatino 2012-11-16 03:54:05 EST
Fedora-18-Beta-TC9-i386-DVD.iso : 4613734400 bytes (4.6137 GB)
Fedora-18-Beta-TC9-x86_64-DVD.iso : 4558159872 bytes (4.558 GB)

These are within the size limit, but just barely. The i386 DVD was close to the size limit in 18 Beta TC1 through TC7 before going over in TC8, and this is closer than it was before TC8. Might be good to try to reduce the size as soon as it gets within a certain percentage of the limit, rather than ignoring it until it goes over (otherwise we might have RCs that are fine except for size).
Comment 17 Jaroslav Reznik 2012-11-16 05:00:22 EST
(In reply to comment #11)
> MATE excluded in git rev 11165f6.

We still need imsettings-mate excluded from kickstart, not only mate-*, see https://bugzilla.redhat.com/show_bug.cgi?id=877313
Comment 18 Bill Nottingham 2012-11-16 11:05:45 EST
(In reply to comment #17)
> (In reply to comment #11)
> > MATE excluded in git rev 11165f6.
> 
> We still need imsettings-mate excluded from kickstart, not only mate-*, see
> https://bugzilla.redhat.com/show_bug.cgi?id=877313

Done.
Comment 19 Bill Nottingham 2012-11-16 11:12:04 EST
Note that excluding imsettings-mate only really helps for repoclosure on the DVD to not be broken; it's not going to affect the size much.

Note that even with the texlive update, we still have a lot of texlive packages on the DVD:

texlive
texlive-ae
texlive-algorithms
texlive-amscls
texlive-amsfonts
texlive-amsmath
texlive-anysize
texlive-attachfile
texlive-babel
texlive-babelbib
texlive-base
texlive-beamer
texlive-bera
texlive-beton
texlive-bibtex
texlive-bibtex-bin
texlive-booktabs
texlive-breakurl
texlive-caption
texlive-carlisle
texlive-chngcntr
texlive-cite
texlive-cm
texlive-cmap
texlive-cmsd
texlive-collection-basic
texlive-collection-documentation-base
texlive-collection-latex
texlive-collection-latexrecommended
texlive-colortbl
texlive-crop
texlive-csquotes
texlive-ctable
texlive-currfile
texlive-dvipdfm
texlive-dvipdfm-bin
texlive-dvipdfmx
texlive-dvipdfmx-bin
texlive-dvipdfmx-def
texlive-dvipng
texlive-dvipng-bin
texlive-dvips
texlive-dvips-bin
texlive-ec
texlive-enctex
texlive-enumitem
texlive-eso-pic
texlive-etex
texlive-etex-pkg
texlive-etoolbox
texlive-euler
texlive-extsizes
texlive-fancybox
texlive-fancyhdr
texlive-fancyref
texlive-fancyvrb
texlive-filecontents
texlive-filehook
texlive-fix2col
texlive-float
texlive-fontspec
texlive-footmisc
texlive-fp
texlive-geometry
texlive-glyphlist
texlive-graphics
texlive-gsftopk
texlive-gsftopk-bin
texlive-hyperref
texlive-hyphen-base
texlive-hyph-utf8
texlive-ifetex
texlive-ifluatex
texlive-ifxetex
texlive-index
texlive-jknapltx
texlive-kastrup
texlive-koma-script
texlive-kpathsea
texlive-kpathsea-bin
texlive-kpathsea-lib
texlive-l3experimental
texlive-l3kernel
texlive-l3packages
texlive-latex
texlive-latex-bin
texlive-latex-bin-bin
texlive-latexconfig
texlive-latex-fonts
texlive-listings
texlive-lm
texlive-ltxmisc
texlive-lua-alt-getopt
texlive-lualatex-math
texlive-luaotfload
texlive-luaotfload-bin
texlive-luatex
texlive-luatexbase
texlive-luatex-bin
texlive-makeindex
texlive-makeindex-bin
texlive-marginnote
texlive-mdwtools
texlive-memoir
texlive-metafont
texlive-metafont-bin
texlive-metalogo
texlive-mflogo
texlive-mfnfss
texlive-mfware
texlive-mfware-bin
texlive-mh
texlive-microtype
texlive-minitoc
texlive-misc
texlive-mparhack
texlive-mptopdf
texlive-mptopdf-bin
texlive-ms
texlive-multido
texlive-natbib
texlive-notoccite
texlive-ntgclass
texlive-oberdiek
texlive-paralist
texlive-parallel
texlive-parskip
texlive-pdfpages
texlive-pdftex
texlive-pdftex-bin
texlive-pdftex-def
texlive-pgf
texlive-placeins
texlive-plain
texlive-powerdot
texlive-psfrag
texlive-pslatex
texlive-psnfss
texlive-pspicture
texlive-pst-3d
texlive-pst-blur
texlive-pst-coil
texlive-pst-eps
texlive-pst-fill
texlive-pst-grad
texlive-pst-math
texlive-pst-node
texlive-pst-plot
texlive-pstricks
texlive-pstricks-add
texlive-pst-slpe
texlive-pst-text
texlive-pst-tree
texlive-qstest
texlive-rcs
texlive-rotating
texlive-sansmath
texlive-sauerj
texlive-scheme-basic
texlive-section
texlive-seminar
texlive-sepnum
texlive-setspace
texlive-showexpl
texlive-soul
texlive-subfig
texlive-tetex
texlive-tetex-bin
texlive-tex
texlive-tex-bin
texlive-texconfig
texlive-texconfig-bin
texlive-texlive-common-doc
texlive-texlive-en-doc
texlive-texlive.infra
texlive-texlive.infra-bin
texlive-texlive-msg-translations
texlive-texlive-scripts
texlive-texlive-scripts-bin
texlive-textcase
texlive-thumbpdf
texlive-thumbpdf-bin
texlive-tipa
texlive-tools
texlive-type1cm
texlive-typehtml
texlive-ucs
texlive-underscore
texlive-unicode-math
texlive-url
texlive-varwidth
texlive-xcolor
texlive-xdvi
texlive-xdvi-bin
texlive-xkeyval
texlive-xunicode
Comment 20 Fedora Update System 2012-11-16 21:29:47 EST
Package texlive-2012-8.20121115_r28267.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-2012-8.20121115_r28267.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18380/texlive-2012-8.20121115_r28267.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2012-11-20 02:17:47 EST
texlive-2012-8.20121115_r28267.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.