Bug 875393 - TypeError: _refresh_device_cfg() takes exactly 3 arguments (2 given)
TypeError: _refresh_device_cfg() takes exactly 3 arguments (2 given)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
AcceptedBlocker abrt_hash:befe48b66ac...
:
: 875414 876485 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-10 17:39 EST by satellitgo
Modified: 2012-11-23 02:49 EST (History)
15 users (show)

See Also:
Fixed In Version: anaconda-18.29-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:49:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (251.05 KB, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: product (6 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: type (9 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: ifcfg.log (631 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: storage.log (84.38 KB, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: version (11 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: environ (780 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: executable (14 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: anaconda.log (5.68 KB, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: syslog (87.13 KB, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: release (24 bytes, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
File: program.log (40.18 KB, text/plain)
2012-11-10 17:39 EST, satellitgo
no flags Details
snapshot of the MAIN HUB with a NETWORKING personality :-) (107.67 KB, image/png)
2012-11-10 18:10 EST, Reartes Guillermo
no flags Details

  None (edit)
Description satellitgo 2012-11-10 17:39:07 EST
Description of problem:
try to configure TC8 x86_64 wireless network (wep) this worked in last smoke

Version-Release number of selected component:
anaconda-18.28

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.28 exception report
:Traceback (most recent call first):
:TypeError: _refresh_device_cfg() takes exactly 3 arguments (2 given)
Comment 1 satellitgo 2012-11-10 17:39:10 EST
Created attachment 642415 [details]
File: anaconda-tb
Comment 2 satellitgo 2012-11-10 17:39:12 EST
Created attachment 642416 [details]
File: product
Comment 3 satellitgo 2012-11-10 17:39:13 EST
Created attachment 642417 [details]
File: type
Comment 4 satellitgo 2012-11-10 17:39:15 EST
Created attachment 642418 [details]
File: ifcfg.log
Comment 5 satellitgo 2012-11-10 17:39:16 EST
Created attachment 642419 [details]
File: storage.log
Comment 6 satellitgo 2012-11-10 17:39:18 EST
Created attachment 642420 [details]
File: version
Comment 7 satellitgo 2012-11-10 17:39:19 EST
Created attachment 642421 [details]
File: environ
Comment 8 satellitgo 2012-11-10 17:39:21 EST
Created attachment 642422 [details]
File: executable
Comment 9 satellitgo 2012-11-10 17:39:22 EST
Created attachment 642423 [details]
File: anaconda.log
Comment 10 satellitgo 2012-11-10 17:39:23 EST
Created attachment 642424 [details]
File: syslog
Comment 11 satellitgo 2012-11-10 17:39:25 EST
Created attachment 642425 [details]
File: hashmarkername
Comment 12 satellitgo 2012-11-10 17:39:26 EST
Created attachment 642426 [details]
File: packaging.log
Comment 13 satellitgo 2012-11-10 17:39:28 EST
Created attachment 642427 [details]
File: cmdline_file
Comment 14 satellitgo 2012-11-10 17:39:29 EST
Created attachment 642428 [details]
File: release
Comment 15 satellitgo 2012-11-10 17:39:30 EST
Created attachment 642429 [details]
File: program.log
Comment 16 satellitgo 2012-11-10 17:47:33 EST
dd FC18 Beta TC8 DVD to 8 GB USB (passed file checking ~ 3 min wait)
failed when I selected network wireless and clicked [configure]
Comment 17 Reartes Guillermo 2012-11-10 18:03:31 EST
I will explain later, since this report might fail (i re-enabled the network manually for abrt).

Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 18 Reartes Guillermo 2012-11-10 18:10:32 EST
Created attachment 642439 [details]
snapshot of the MAIN HUB with a NETWORKING personality :-)

For comment #17 (mine)

0. Enter NETWORK, select 'configure'

1. Click outside of the Dialog, the dialog 'goes to the background' and ALT+TAB does not work.

2. If one returns to the MAIN HUB, the result is the snapshot.

3. But if one changes something while the Dialog is in the background, returns to the MAIN HUB and tries to go back to NETWORKING again, the error i reported happens. I re-enabled the network and let ABRT report it. So if it is another bug, it is not my fault...
Comment 19 satellitgo 2012-11-10 18:35:44 EST
Retested again:
This occurs as soon as Wireless (wlan0) is selected. There is no time to select the network dropdown or [configure] button
Comment 20 satellitgo 2012-11-11 11:47:37 EST
start DVD i386 with network unplugged went right to network spoke and failed

Package: anaconda-18.28
Architecture: i686
OS Release: Fedora release 18-Beta-TC8
Comment 21 satellitgo 2012-11-11 11:54:36 EST
ready to install with wired network connected Ethernet (em1) 
If you enter the Networking Configuration spoke and click on wireless:
Wireless (wlan0) fails immediately
Comment 22 satellitgo 2012-11-11 13:48:11 EST
TC8 netinstall crashes as soon as enter network spoke and clicking on wireless DHCP wired is on and working at this time

Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 23 Fomalhaut 2012-11-11 13:55:58 EST
The error appears after selecting the language when installing the system from LiveCD with XFCE Fedora-18-Beta-TC8-x86_64-Live-XFCE.iso

Package: anaconda-18.28-1.fc18.x86_64
OS Release: Fedora 18 beta TC8 x86-64
Comment 24 satellitgo 2012-11-11 14:03:18 EST
TC8 f18-live Desktop i686 installs correctly (be sure to not use first screen off to install if using wireless- connect to wireless on running live CD then install as the connection information is transferred to the HD install)
Comment 25 Chris Lumens 2012-11-11 23:25:14 EST
*** Bug 875414 has been marked as a duplicate of this bug. ***
Comment 26 Radek Vykydal 2012-11-12 05:03:41 EST
I'll file a separate bug for issue from comment #18.
Comment 27 satellitgo 2012-11-12 05:22:55 EST
This bug does not happen, so it would not be noticed, in VirtualBox as network always is present and no wireless is used
Comment 28 Kamil Páral 2012-11-12 14:22:57 EST
I saw this immediately after selecting language and "accepting my fate". Bare metal with network cable unplugged and wifi enabled but not connected. In other words, no network connection.

Package: anaconda-18.28-1.fc18.x86_64
OS Release: Fedora release 18
Comment 29 Kamil Páral 2012-11-12 14:28:59 EST
Proposing as Beta blocker as well, this is quite serious. We don't have any "offline install must work" criterion, but we should consider adding one.
Comment 30 Fedora Update System 2012-11-12 20:24:18 EST
anaconda-18.29-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.29-1.fc18
Comment 31 Kamil Páral 2012-11-13 06:01:11 EST
This is fixed in anaconda 18.29 (smoke18).
Comment 32 Radek Vykydal 2012-11-13 08:26:30 EST
(In reply to comment #26)
> I'll file a separate bug for issue from comment #18.

Bug 876020.
Comment 33 Fedora Update System 2012-11-13 14:07:31 EST
Package anaconda-18.29-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18105/anaconda-18.29-1.fc18
then log in and leave karma (feedback).
Comment 34 Adam Williamson 2012-11-14 05:15:31 EST
Voting in advance of blocker meeting tomorrow, which I likely won't be around for: +1 blocker as a conditional breakage of 'installer must work' criterion (pick any one...) in the case of wireless connection or (apparently) no connection but wifi available (viz kparal).
Comment 35 Radek Vykydal 2012-11-14 06:02:59 EST
*** Bug 876485 has been marked as a duplicate of this bug. ***
Comment 36 Kamil Páral 2012-11-14 12:17:15 EST
Discussed at 2012-11-14 blocker bug meeting. Accepted as a blocker: Violates the following F18 alpha release criterion for machines without a working network connection at boot time: "The installer must boot and run on all primary architectures, with all system firmware types that are common on those architectures ..."
Comment 37 Bastien Nocera 2012-11-15 01:56:30 EST
Got to the network setup page

Package: anaconda-18.28-1.fc18.x86_64
OS Release: Fedora release 18
Comment 38 Bastien Nocera 2012-11-15 02:15:17 EST
Choose language, clicked next

Package: anaconda-18.28-1.fc18.x86_64
OS Release: Fedora release 18
Comment 39 William Brown 2012-11-15 09:37:31 EST
Fresh boot of anaconda on a system with a previous install of fedora 15

Package: anaconda-18.28
OS Release: Fedora release 18-Beta-TC8
Comment 40 Gianluca Cecchi 2012-11-18 19:10:19 EST
I confirm that with F18 Beta-TC9 x86_64 netinst.iso I don't have anymore this problem I had with TC8.
Thanks,
Gianluca
Comment 41 Fedora Update System 2012-11-23 02:49:36 EST
anaconda-18.29-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.