Bug 875414 - Anaconda throws exception if DHCP lease not available with netinstall / any type of install
Summary: Anaconda throws exception if DHCP lease not available with netinstall / any t...
Keywords:
Status: CLOSED DUPLICATE of bug 875393
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F18-accepted, F18FinalFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2012-11-11 04:05 UTC by Shawn Starr
Modified: 2012-11-12 04:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-12 04:25:14 UTC
Type: Bug


Attachments (Terms of Use)
test attachment, please ignore (7 bytes, text/plain)
2012-11-11 04:13 UTC, Kevin Fenzi
no flags Details
another test. (7 bytes, text/plain)
2012-11-11 04:28 UTC, Kevin Fenzi
no flags Details
Anaconda install dump + stacktrace (142.43 KB, text/plain)
2012-11-11 04:42 UTC, Shawn Starr
no flags Details

Description Shawn Starr 2012-11-11 04:05:39 UTC
Description of problem:

When installing Fedora with netinst or gPXE (BFO) installations, if no DHCP lease is available Anaconda throws exception and fails.

Version-Release number of selected component (if applicable):
TC8 (likely any Anaconda builds for F18)

How reproducible: 100%


Steps to Reproduce:
1. Have a DHCP server that is IP per mac bound restricted
1. Using a VM or physical host, install via netinst / gPXE method
2. Attempt to install, X starts, choose language, then crashes
 
Actual results:
Crashes with a stack trace

Expected results:
Should show an error or prompt you to re-try network detection OR fall back to static IP

Additional info:

See attach for full dump and anaconda output

Comment 1 Kevin Fenzi 2012-11-11 04:13:17 UTC
Created attachment 642552 [details]
test attachment, please ignore

Comment 2 Kevin Fenzi 2012-11-11 04:28:53 UTC
Created attachment 642553 [details]
another test.

Comment 3 Shawn Starr 2012-11-11 04:42:02 UTC
Created attachment 642566 [details]
Anaconda install dump + stacktrace

Comment 4 Shawn Starr 2012-11-11 06:14:40 UTC
Regression, we used to fall back to manual configuration in GUI if no DHCP available

Comment 5 Chris Lumens 2012-11-12 04:25:14 UTC

*** This bug has been marked as a duplicate of bug 875393 ***


Note You need to log in before you can comment on or make changes to this bug.