Bug 875420 - Anaconda fails if not enough memory ie (512MB)
Anaconda fails if not enough memory ie (512MB)
Status: CLOSED DUPLICATE of bug 875418
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-11 00:10 EST by Shawn Starr
Modified: 2012-11-11 00:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-11 00:36:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shawn Starr 2012-11-11 00:10:05 EST
Description of problem:

If host or VM has too little memory, ie 512MB anaconda throws exception and locks up.

Version-Release number of selected component (if applicable):
Any TCX release

How reproducible:
100%

Steps to Reproduce:
1. Set a KVM VM instance to 512MB for memory
2. Attempt to install
3. Select timezone, repeatedly trying to select this while it attempts to spawn systemctl fails, anaconda crashes/hangs
  
Actual results:
Crashes

Expected results:
Should prompt user they have not enough memory and stop install.
Comment 1 Shawn Starr 2012-11-11 00:25:21 EST
old Anaconda would inform you of not enough memory and gracefully abort. New Anaconda UI fails in a poor user experience
Comment 2 Shawn Starr 2012-11-11 00:36:46 EST

*** This bug has been marked as a duplicate of bug 875418 ***

Note You need to log in before you can comment on or make changes to this bug.