Bug 875418 - Anaconda fails if not enough memory ie (512MB)
Anaconda fails if not enough memory ie (512MB)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 873343 875420 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-11 00:07 EST by Shawn Starr
Modified: 2012-12-18 05:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 05:00:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda without swap (44.84 KB, image/png)
2012-12-17 07:53 EST, Kamil Páral
no flags Details

  None (edit)
Description Shawn Starr 2012-11-11 00:07:49 EST
Description of problem:

If host or VM has too little memory, ie 512MB anaconda throws exception and locks up.

Version-Release number of selected component (if applicable):
Any TCX release

How reproducible:
100%

Steps to Reproduce:
1. Set a KVM VM instance to 512MB for memory
2. Attempt to install
3. Select timezone, repeatedly trying to select this while it attempts to spawn systemctl fails, anaconda crashes/hangs
  
Actual results:
Crashes

Expected results:
Should prompt user they have not enough memory and stop install.
Comment 1 Shawn Starr 2012-11-11 00:36:46 EST
*** Bug 875420 has been marked as a duplicate of this bug. ***
Comment 2 Shawn Starr 2012-11-11 01:13:34 EST
This is a regression
Comment 3 Steve Tyler 2012-11-12 01:52:52 EST
I can't reproduce this using 512 MB memory and the F18-Beta-TC8 DVD.

Test procedure:

1. Create a 12 GB empty disc image:
$ qemu-img create f18-test-2.img 12G

2. Start the installer from the DVD with 512 GB memory:
$ qemu-kvm -m 512 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse

3. Select a time zone.

4. Select a minimal install.

5. Auto-create partitions and filesystems:
   Click Installation Destination.
   Click Done.
   NB: This creates a 992 MB swap space on a logical volume.

6. Begin Installation.

The install completes and the target boots without apparent error.
Comment 4 Steve Tyler 2012-11-12 02:35:54 EST
With 512 MB memory, the F18-Beta-TC8 Live CD boots to the desktop, and a terminal can be started. If the installer is launched, a white disk that moves with the mouse is visible, but the installer welcome panel is never displayed. The desktop becomes unresponsive.

Tested with:
$ qemu-img create f18-test-2.img 12G
$ qemu-kvm -m 512 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse

If the DVD is used to first partition the disc image, so that the disc image contains a swap space, the Live CD installer still fails to start. Swap space is enabled when the Live CD starts, but it is disabled after the installer is launched. Verified by running "top" from a terminal.
Comment 5 Jesse Keating 2012-11-12 11:31:48 EST
Booting the full DVD requires less ram, as the stage2 runs from the DVD, not loaded into memory.  If just booting the kernel and downloading stage2 from the network will require more memory, because stage2 is downloaded into ram.

Booting live media takes more memory too, there is just more stuff running by the time you launch anaconda.

It also depends on the size of your package install set.

With F18 and the rewrite we aren't really sure what our memory requirements are, and what is a bug of too much in use vs this is what we need.
Comment 6 Steve Tyler 2012-11-12 17:46:02 EST
Thanks for the additional details. With 768 MB memory and default partitioning, a Live CD install succeeds:

$ qemu-img create f18-test-2.img 12G
$ qemu-kvm -m 768 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse

From watching "top" during installation from the Live CD, it can be seen that, after configuring the disk, the installer enables swap, which is used during software installation.

I reran the DVD install test using 512 MB memory, default partitioning, and a Gnome desktop package set, and that succeeded too.

Those are excellent results, IMO.
Comment 7 Brian Lane 2012-12-07 14:41:41 EST
I think our memory usage is actually pretty good at this point. Using smoke4:

DVD with 512M works (about 200M swap)
PXE with 512M doesn't work which isn't a surprise. it has to download the install.img into ram.
PXE with 768M works but is a bit slow. Text should be better.
livecd with 512M doesn't work. No surprise here, with the full gnome desktop running.
livecd with 768M works fine.
Comment 8 Chris Lumens 2012-12-10 11:08:11 EST
*** Bug 873343 has been marked as a duplicate of this bug. ***
Comment 9 Kamil Páral 2012-12-17 07:53:51 EST
Created attachment 664823 [details]
anaconda without swap

Brian didn't really describe what was changed. But I tried running anaconda with 512 MB RAM and installing without a swap and it correctly says I don't have enough memory for that. See screenshot. Thus marking as VERIFIED.
Comment 10 Kamil Páral 2012-12-17 07:56:21 EST
I forgot to mention it was anaconda 18.37.2 from TC2 (which is stable now).

Brian, does it mean the fix is already pushed and we can close this bug without waiting for the NTH process to happen? Or do you have some further patches prepared?
Comment 11 Brian Lane 2012-12-17 13:09:55 EST
Nothing has been changes. I think our current limits are just fine.
Comment 12 Kamil Páral 2012-12-18 05:00:30 EST
Closing then.

Note You need to log in before you can comment on or make changes to this bug.