Bug 875477 - ValueError: name already in use
Summary: ValueError: name already in use
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3b240e77666effa70d72974441b...
: 875497 (view as bug list)
Depends On:
Blocks: F18Blocker, F18FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2012-11-11 14:28 UTC by Reartes Guillermo
Modified: 2013-08-20 18:24 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-06 07:27:52 UTC


Attachments (Terms of Use)
File: anaconda-tb (230.23 KB, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: storage.log (92.14 KB, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: executable (14 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: anaconda.log (9.38 KB, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: syslog (62.01 KB, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-11-11 14:28 UTC, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-11-11 14:29 UTC, Reartes Guillermo
no flags Details
File: program.log (26.34 KB, text/plain)
2012-11-11 14:29 UTC, Reartes Guillermo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 998741 None None None Never

Internal Links: 998741

Description Reartes Guillermo 2012-11-11 14:28:00 UTC
Description of problem:
selected one disk of a previous btrfs instance, went to manual partitioning and deleted partitons.
used the guided partitioning to propose partitions, kaboom


Version-Release number of selected component:
anaconda-18.28

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.28 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1134, in newLV
:    raise ValueError("name already in use")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 267, in _scheduleVolumes
:    dev = new_volume(**kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 306, in doAutoPartition
:    _scheduleVolumes(storage, devs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1861, in _do_autopart
:    doAutoPartition(self.__storage, self.data)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1893, in on_create_clicked
:    self._do_autopart()
:ValueError: name already in use

Comment 1 Reartes Guillermo 2012-11-11 14:28:12 UTC
Created attachment 642842 [details]
File: anaconda-tb

Comment 2 Reartes Guillermo 2012-11-11 14:28:14 UTC
Created attachment 642844 [details]
File: product

Comment 3 Reartes Guillermo 2012-11-11 14:28:16 UTC
Created attachment 642846 [details]
File: type

Comment 4 Reartes Guillermo 2012-11-11 14:28:20 UTC
Created attachment 642848 [details]
File: ifcfg.log

Comment 5 Reartes Guillermo 2012-11-11 14:28:27 UTC
Created attachment 642849 [details]
File: storage.log

Comment 6 Reartes Guillermo 2012-11-11 14:28:31 UTC
Created attachment 642850 [details]
File: version

Comment 7 Reartes Guillermo 2012-11-11 14:28:34 UTC
Created attachment 642851 [details]
File: environ

Comment 8 Reartes Guillermo 2012-11-11 14:28:40 UTC
Created attachment 642852 [details]
File: executable

Comment 9 Reartes Guillermo 2012-11-11 14:28:43 UTC
Created attachment 642853 [details]
File: anaconda.log

Comment 10 Reartes Guillermo 2012-11-11 14:28:48 UTC
Created attachment 642854 [details]
File: syslog

Comment 11 Reartes Guillermo 2012-11-11 14:28:50 UTC
Created attachment 642855 [details]
File: hashmarkername

Comment 12 Reartes Guillermo 2012-11-11 14:28:55 UTC
Created attachment 642856 [details]
File: packaging.log

Comment 13 Reartes Guillermo 2012-11-11 14:28:57 UTC
Created attachment 642857 [details]
File: cmdline_file

Comment 14 Reartes Guillermo 2012-11-11 14:29:00 UTC
Created attachment 642858 [details]
File: release

Comment 15 Reartes Guillermo 2012-11-11 14:29:04 UTC
Created attachment 642859 [details]
File: program.log

Comment 16 Reartes Guillermo 2012-11-11 14:32:14 UTC
Enhanced steps to reproduce:

0. Enter STORAGE: INSTALLATION DESTINATION
1. Select one DISK
2. Go to MANUAL PARTITIONING
3. Delete the found BTRFS and the prior /boot partitions
4. Use the guide or wizard to propose partitions and 'finish partitioning'

Comment 17 Reartes Guillermo 2012-11-11 14:35:28 UTC
Corrected step #4.

Enhanced steps to reproduce:

0. Enter STORAGE: INSTALLATION DESTINATION
1. Select one DISK
2. Go to MANUAL PARTITIONING
3. Delete the found BTRFS and the prior /boot partitions

4. Use the guide or wizard the error happens after clicking the guided partitioning, it is not possible to reach the 'finish partitioning' button.

Comment 18 Chris Lumens 2012-11-12 04:19:48 UTC
*** Bug 875497 has been marked as a duplicate of this bug. ***

Comment 19 Reartes Guillermo 2012-11-16 14:31:41 UTC
i selected some disks, went to automatic partitioning and reclaimed space. i only set a btrfs to 'shrink' 

Package: anaconda-18.29
OS Release: Fedora release 18-Beta-TC9

Comment 20 David Lehman 2012-11-16 17:03:31 UTC
The check for name already in use in newLV is only checking the LV name when what matters is $vgname-$lvname.

Comment 21 Adam Williamson 2012-11-29 18:46:44 UTC
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . Accepted as a blocker per criterion "The installer's custom partitioning mode must be capable of the following: Creating, destroying and assigning mount points to partitions of any specified size using most commonly-used filesystem types ...".

Comment 22 Fedora Update System 2012-12-02 00:27:35 UTC
pykickstart-1.99.22-1.fc18, anaconda-18.34-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.34-1.fc18

Comment 23 Fedora Update System 2012-12-02 19:27:13 UTC
Package pykickstart-1.99.22-1.fc18, anaconda-18.34-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.34-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.34-1.fc18
then log in and leave karma (feedback).

Comment 24 Kamil Páral 2012-12-03 15:24:02 UTC
Reartes, could you please try to reproduce again with this image?
http://dl.fedoraproject.org/pub/alt/qa/20121201_f18-smoke2/

It contains the latest anaconda. It should hopefully fix the issue. Thanks.

Comment 25 Fedora Update System 2012-12-05 23:12:11 UTC
Package pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.35-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
then log in and leave karma (feedback).

Comment 26 Fedora Update System 2012-12-06 07:27:55 UTC
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Kamil Páral 2012-12-06 11:54:23 UTC
Reartes, can you verify this is fixed? Please try this image:
http://dl.fedoraproject.org/pub/alt/qa/20121205_f18-smoke4/
Thanks.

Comment 28 Reartes Guillermo 2012-12-07 13:46:43 UTC
@Kamil Páral

I reproduced the issue first, then tried on the same guest with the smoke4 (netinstall) and there was no error. It looks the issue is fixed.

Thanks.

Comment 29 Kamil Páral 2012-12-10 08:54:27 UTC
Thank you, Reartes.


Note You need to log in before you can comment on or make changes to this bug.