Bug 875559 - Add introduction in man page of remote-viewer about connecting to rhel guest with multiple monitors.
Add introduction in man page of remote-viewer about connecting to rhel guest ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
:
: 875563 875564 875565 (view as bug list)
Depends On:
Blocks: 921342 977086
  Show dependency treegraph
 
Reported: 2012-11-11 21:21 EST by Geyang Kong
Modified: 2013-11-21 03:03 EST (History)
13 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
no doc required
Story Points: ---
Clone Of:
: 921342 977086 (view as bug list)
Environment:
Last Closed: 2013-11-21 03:03:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.13 KB, patch)
2013-05-09 21:08 EDT, Marc-Andre Lureau
no flags Details | Diff

  None (edit)
Description Geyang Kong 2012-11-11 21:21:52 EST
Description of problem:
  Add introduction in man page of remote-viewer about connecting to rhel guest with multiple monitors.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64

Reproduce steps:
1. man remote-viewer

Actual results:
1. There is nothing about new functions of --full-screen=auto-conf.

Expected results:
1. Since bug 842305 has given some new functions to --full-screen=auto-conf, we should add something to introduce this and tell user how to connect to a rhel guest with multiple monitors.

Additional info:
Comment 3 Geyang Kong 2012-11-11 22:06:03 EST
*** Bug 875565 has been marked as a duplicate of this bug. ***
Comment 4 Geyang Kong 2012-11-11 22:06:27 EST
*** Bug 875564 has been marked as a duplicate of this bug. ***
Comment 5 Geyang Kong 2012-11-11 22:06:39 EST
*** Bug 875563 has been marked as a duplicate of this bug. ***
Comment 8 Marc-Andre Lureau 2013-05-09 21:08:21 EDT
Created attachment 745863 [details]
proposed patch
Comment 9 Marc-Andre Lureau 2013-05-09 21:09:08 EDT
is attached patch ok?
Comment 10 Christophe Fergeau 2013-05-13 08:05:30 EDT
s/initilialization/initialization
The " enabling or disabling extra monitors when necessary" could be clearer I think, I don't really understand what this is about by just reading it.
Comment 11 Marc-Andre Lureau 2013-05-13 08:29:03 EDT
So what about just:

If given the argument 'auto-conf', the remote server will be
reconfigured to try to match the client physical monitor configuration
when starting the connection. This is currently implemented by the Spice
backend only.
Comment 12 Christophe Fergeau 2013-05-13 10:02:27 EDT
Maybe " If given..., the guest display configuration will be changed to try to match ..." ?
Comment 13 Christophe Fergeau 2013-05-24 10:39:56 EDT
Marc-André, can you send a patch to virt-tools-list so that we get this in?
Comment 17 CongDong 2013-07-03 07:52:25 EDT
I can reproduce this bug:
version:
# rpm -qa virt-viewer
virt-viewer-0.5.2-18.el6_4.2.x86_64

steps:
# man remote-viewer

result:
...
-f, --full-screen
           Start with the window maximised to fullscreen
...

Verify:
version:
# rpm -qa virt-viewer
virt-viewer-0.5.6-1.el6.x86_64

Steps:
# man remote-viewer

result:
...
-f, --full-screen=<auto-conf>
           Start with the windows maximized to fullscreen.

           If the argument ’auto-conf’ is given, the remote display will be reconfigured to match at best the client physical monitor
           configuration on initialization, by enabling or disabling extra monitors as necessary. This is currently implemented by the Spice
           backend only.
...

As the result, the bug is fixed.
Comment 20 errata-xmlrpc 2013-11-21 03:03:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html

Note You need to log in before you can comment on or make changes to this bug.