Bug 875697 - remote-viewer: "Unable to connect to the graphic server" error on guest shutdown
Summary: remote-viewer: "Unable to connect to the graphic server" error on guest shutdown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: Unspecified
OS: All
unspecified
high
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 921519
TreeView+ depends on / blocked
 
Reported: 2012-11-12 11:49 UTC by Milan Barta
Modified: 2017-02-06 15:16 UTC (History)
12 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Shutdown guest while client stay connected. Consequence: "Unable to connect to the graphic server" error is shown to user. Fix: Do not report error on normal disconnection. Result: No error message displayed when shuting down a guest.
Clone Of:
: 913080 921519 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:03:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
remote-viewer --spice-debug (483.80 KB, text/plain)
2012-11-12 11:49 UTC, Milan Barta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Milan Barta 2012-11-12 11:49:35 UTC
Created attachment 643469 [details]
remote-viewer --spice-debug

Description of problem:
After guest system shut down is initiated from remote-viewer, the window isn't closed automatically and an error message "Unable to connect to the graphic server" appears.
The guest system shuts down and remote-viewer disconnects successfully however (see remote-viewer log attached).

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64
spice-gtk-0.14-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. connect to a running VM using remote-viewer
2. initiate guest system shut down from inside the remote-viewer
3. keep the remote-viewer window open until the guest system shuts down
  
Actual results:
An error message "Unable to connect to the graphic server" appears and the remote-viewer window isn't closed.

Expected results:
The remote-viewer window is closed without an error.

Additional info:

Comment 1 Marc-Andre Lureau 2012-11-14 20:28:25 UTC
we should fix that one, it looks like an error when it is not, and the fix shouldn't be too complicated hopefully. should we devel_ack that one?

Comment 2 Marc-Andre Lureau 2012-11-20 11:40:25 UTC
taking a look

Comment 3 Marc-Andre Lureau 2012-11-20 12:07:16 UTC
sent patch to ML:
https://www.redhat.com/archives/virt-tools-list/2012-November/msg00190.html

Comment 12 tingting zheng 2013-07-05 06:34:19 UTC
I can reproduce this bug with:
virt-viewer-0.5.2-18.el6_4.2.x86_64

Tested the bug with:
virt-viewer-0.5.6-2.el6.x86_64

Steps:
1. connect to a running VM using remote-viewer
2. initiate guest system shut down from inside the remote-viewer
3. keep the remote-viewer window open until the guest system shuts down
  
The remote-viewer window is closed without an error,so move the bug to VERIFIED.

Comment 13 errata-xmlrpc 2013-11-21 08:03:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.