Bug 876091 - Can not use free space to partition
Can not use free space to partition
Status: CLOSED DUPLICATE of bug 951269
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-13 04:52 EST by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-19.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 12:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (68.96 KB, image/png)
2012-11-13 04:52 EST, Tao Wu
no flags Details
screenshot showing 2.68 GB required, 3 GB free space available for use (84.83 KB, image/png)
2012-11-13 16:46 EST, Steve Tyler
no flags Details
storage log (64.42 KB, text/x-log)
2012-11-13 21:56 EST, Tao Wu
no flags Details
packging log (2.28 KB, text/x-log)
2012-11-13 21:57 EST, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2012-11-13 04:52:32 EST
Created attachment 644015 [details]
screenshot

Description of problem:
Anaconda can not use free space to partition, even though the available free space is big enough. From the screenshot in the attachment, we can see that the required space is 2.72GB, and while the "Free space available for use" is 3.68GB. It does not make sense.

Version-Release number of selected component (if applicable):
18.28

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2012-11-13 09:15:56 EST
Please attach /tmp/storage.log and /tmp/packaging.log to this bug report.
Comment 2 David Lehman 2012-11-13 12:58:10 EST
The total space requirement for automatic partitioning includes the space requirement for the currently software selection as well as the size of the swap device that would be created during automatic partitioning. The swap value is not represented in the dialog.
Comment 3 Steve Tyler 2012-11-13 16:46:50 EST
Created attachment 644402 [details]
screenshot showing 2.68 GB required, 3 GB free space available for use

I reproduced the same situation using the Live CD as follows:

Remove all partitions on a 12 GB disc image and use the installer to create these Standard Partitions:

1       /boot        500
2       /           3000
3       swap         500
4       [extended]
5       /home       1000
        [unused]    7000
Total              12000

Complete the install and reboot the Live CD.

Install gparted and use it to make these changes:

1. Delete partition 2 ("/").
2. Create a new partition from the remaining 7000 MB space.
3. Format the new 7000 MB partition as ext4.

Reboot the Live CD and start the installer.

Tested with:
anaconda 18.29 (updated from 18.28 on the F18-Beta-TC8 Live CD)
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 4 Tao Wu 2012-11-13 21:56:42 EST
Created attachment 644517 [details]
storage log
Comment 5 Tao Wu 2012-11-13 21:57:11 EST
Created attachment 644518 [details]
packging log
Comment 6 Tao Wu 2012-11-13 21:58:10 EST
The storage.log and packaging.log have been uploaded.
Comment 7 David Lehman 2013-05-16 12:25:51 EDT

*** This bug has been marked as a duplicate of bug 951269 ***

Note You need to log in before you can comment on or make changes to this bug.