Bug 951269 - 'Not enough space' UI dialog text doesn't reflect required space for swap
'Not enough space' UI dialog text doesn't reflect required space for swap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 876091 952512 957368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-11 17:54 EDT by Máirín Duffy
Modified: 2013-05-16 12:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-19.22-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-30 00:44:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2013-04-11 17:54:56 EDT
Description of problem:

I've been reviewing the usability test video from Brno. In Video 3/  User 2 / 1361621939636667, the user attempts to install Fedora dual-boot with a pre-existing Windows installation (on a VM).

The disk is 10 GB large. The Windows install takes up roughly 9 GB. The user did not do custom partitioning; they selected the 10 GB disk and when exiting the disk selection screen were informed there wasn't enough free space on disk and they'd need to reclaim at least 3.47 GB of space to install Fedora.

The user used the reclaim space dialog and freed 5 GB of space from the Windows 9 GB partition, shrinking Windows down to 4 GB.

When the user exited the reclaim space dialog, they were told they still didn't have enough space. The dialog specifically said they needed 3.47 GB to install Fedora and had 5.09 GB of space free. This doesn't make sense and the user was quite confused as what to do. 

I talked to dlehman about this in IRC and he said he thinks that the system probably would require > 1.5GB of swap that isn't accounted for in the 3.47 GB number. So the UI figure of '#.47 GB' is not reflecting the installer's actual space requirement, which is higher.

So the bug here is that the number that the 'not enough space' dialog presents to the user does not include the amount of space they need for swap, depending on their system's memory. It should so users know how much space to free up to successfully finish the install.

Version-Release number of selected component (if applicable):

It was Fedora 18 GA on a VM in Brno, but the bug is still present in F19.
Comment 1 Máirín Duffy 2013-04-11 19:19:50 EDT
Here's a suggested language change for the text to account for this addition of required space:

X = amount of space required to install fedora
Y = amount of space required for swap
Z = X + Y

"Your current software selection requires Z amount of available space, including X for software and Y for recommended swap."
Comment 2 David Lehman 2013-04-16 11:48:26 EDT
*** Bug 952512 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-04-25 00:03:46 EDT
anaconda-19.22-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.22-1.fc19
Comment 4 Fedora Update System 2013-04-25 12:44:49 EDT
Package anaconda-19.22-1.fc19, pykickstart-1.99.28-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.22-1.fc19 pykickstart-1.99.28-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6595/pykickstart-1.99.28-1.fc19,anaconda-19.22-1.fc19
then log in and leave karma (feedback).
Comment 5 Chris Lumens 2013-04-29 09:34:29 EDT
*** Bug 957368 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-04-30 00:44:52 EDT
anaconda-19.22-1.fc19, pykickstart-1.99.28-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 David Lehman 2013-05-16 12:25:52 EDT
*** Bug 876091 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.