Bug 876138 - [rhevm-reports] - input controls labels are not localized
[rhevm-reports] - input controls labels are not localized
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.2.0
Assigned To: Yaniv Dary
Lijun Li
infra
: i18n
Depends On:
Blocks: 892306 918075
  Show dependency treegraph
 
Reported: 2012-11-13 07:40 EST by Yaniv Dary
Modified: 2016-02-10 14:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In Red Hat Enterprise Virtualization Reports, the Input Controls labels are now localized.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 17:59:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed Input Controls lables are localized (19.16 KB, image/png)
2013-01-16 03:20 EST, Lijun Li
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10818 None None None Never

  None (edit)
Description Yaniv Dary 2012-11-13 07:40:50 EST
Description of problem:
Apparently there is a way to localize the input controls labels. This should be added to the existing localization.
Link to explanation: 
http://www.scribd.com/doc/90728598/44/Adding-a-Multi-Lingual-Prompt-and-Static-List-to-an-Input-Control 

Version-Release number of selected component (if applicable):
3.1.0

How reproducible:
always

Steps to Reproduce:
1. run reports portal in a localized session.
2. run a report
  
Actual results:
input controls labels are in english

Expected results:
labels should be in the same language.

Additional info:
Comment 4 Yaniv Dary 2013-01-09 09:13:32 EST
Added ability to do this in patch:
http://gerrit.ovirt.org/#/c/10818/



Yaniv
Comment 6 Lijun Li 2013-01-16 03:14:58 EST
Verified on the latest rhevm si build, it's fixed.

# rpm -q rhevm rhevm-webadmin-portal rhevm-reports
rhevm-3.1.0-41.el6ev.noarch
rhevm-webadmin-portal-3.1.0-41.el6ev.noarch
rhevm-reports-3.1.0-20.el6ev.noarch

The Input Controls labels are localized now, for the input field in the Input Controls window still in English, thought they will be translated later.

Moving to VERIFIED.

Please refer to the attached screen shot.

Thanks,
Robert
Comment 7 Lijun Li 2013-01-16 03:20:16 EST
Created attachment 679415 [details]
Fixed Input Controls lables are localized
Comment 11 errata-xmlrpc 2013-06-10 17:59:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0887.html

Note You need to log in before you can comment on or make changes to this bug.