This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 87620 - provide nano as replacement for pico
provide nano as replacement for pico
Status: CLOSED DUPLICATE of bug 55253
Product: Red Hat Public Beta
Classification: Retired
Component: pine (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-30 22:45 EST by Michael Wardle
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2003-03-30 22:45:54 EST
A number of new Linux users I know find Pico to be the easiest command-line
editor to learn.  This is particularly the case for first year students who
have access to a terminal for introductory operating system or programming
subjects.  Many such users are unfamiliar with (and do not wish to spend the
time to learn) Vim or Emacs, and can not use a GUI text editor.

With Pine and Pico slated for future removal, it will be somewhat
disappointing to lose it.

I am hopeful you will consider supplying the GNU Nano editor, a free clone
of UW Pico in its place.  Indeed, it provides some enhanced functionality
such as search and replace, multiple buffers, and syntax highlighting, so
you might even consider including regardless of the status of Pine.

As you would expect of GNU software, it is licensed under the GNU GPL.
Its home page is <http://www.nano-editor.org>.
Comment 1 Mike A. Harris 2003-04-01 17:58:52 EST
As I commented on the mailing list, there have already been requests submitted
in bugzilla to add nano, and we will consider that request from various people
once pine does get officially removed from the distribution.  There is no
chance nano will be added while pine is still present.

I am closing this bug WONTFIX for now because there is no need to track this
in bugzilla as it is already present in bugzilla, and I'm 200% sure that
when pine does actually get removed, there will be 10000 new RFE submissions
at that juncture.
Comment 2 Michael Wardle 2003-04-01 22:43:08 EST
Mike

Thanks for your response on the list.

I only filed this bug after searching Bugzilla for any open bugs against
Red Hat Linux with "nano" in the summary, and the search resulted in zero
results.

If you are attempting to avoid duplicates and extra work, perhaps it would
be easiest to leave an RFE open so that a bug search finds it.
Comment 3 Mike A. Harris 2003-04-02 14:47:00 EST
No.  The bug status reflects the bug status.  People should search for
both open and closed bugs if they want to really find things.  Ignoring
the purpose of the bug status field and leaving a thousand bugs open
because people can't properly use bugzilla doesn't let bugzilla serve
it's purpose properly.
Comment 4 Mike A. Harris 2003-05-20 03:57:58 EDT

*** This bug has been marked as a duplicate of 55253 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.