Bug 876482 - rhevm-upgrade must check for enough disk space to perform an upgrade before starting the upgrade
rhevm-upgrade must check for enough disk space to perform an upgrade before s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity urgent
: ---
: 3.2.0
Assigned To: Alex Lourie
Ilanit Stein
integration
: ZStream
: 885606 (view as bug list)
Depends On:
Blocks: 891631 915537
  Show dependency treegraph
 
Reported: 2012-11-14 04:27 EST by Ilanit Stein
Modified: 2013-06-11 05:33 EDT (History)
12 users (show)

See Also:
Fixed In Version: sf-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 891631 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2012-11-14 04:27:42 EST
Description of problem:

When rhevm-upgrade failed on yum update (in this case because of lack of space),
rpm roll back failed.

console log:

During the upgrade process, RHEV Manager  will not be accessible.
All existing running virtual machines will continue but you will not be able to
start or stop any new virtual machines during the process.

Would you like to proceed? (yes|no): yes
Stopping ovirt-engine service...                         [ DONE ]
Stopping DB related services...                          [ DONE ]
Pre-upgrade validations...                               [ DONE ]
Backing Up Database...                                   [ DONE ]
Rename Database...                                       [ DONE ]
Updating rpms...                                         [ ERROR ]

 **Error: Upgrade failed, rolling back**
 **Reason: Error: Yum update failed**

Restoring Database...Password: 
                                    [ DONE ]
Rolling back rpms...                                     [ ERROR ]
Starting ovirt-engine...                                 [ DONE ]
Error: Upgrade failed.
please check log at /var/log/ovirt-engine/ovirt-engine-upgrade_2012_11_13_18_04_41.log
(attached)

Version-Release number of selected component (if applicable):

SI24 - upgraded to SI24.1

How reproducible:

always.

Steps to Reproduce:
1. Have yum update fail, for example for disk space, giving failure like:
Transaction Check Error:
  installing package rhev-hypervisor6-6.3-20121107.0.auto133.el6_3.noarch needs 135MB on the / filesystem
  installing package rhev-guest-tools-iso-3.1-9.noarch needs 175MB on the / filesystem
2. yum update rhevm-setup
3. run rhevm-upgrade

  
Expected results:
rpm roll back succeed
Comment 1 Ilanit Stein 2012-11-14 07:01:42 EST
In addition to what mentioned in description,
The notifier service, which go down during rhevm upgrade, stay at down state after the upgrade failure - please fix it, in case this is not the correct behaviour.
Comment 7 Ofer Schreiber 2012-12-05 09:34:19 EST
Patch posted upstream: http://gerrit.ovirt.org/#/c/9744/
Comment 17 Moran Goldboim 2013-02-12 06:01:55 EST
*** Bug 885606 has been marked as a duplicate of this bug. ***
Comment 18 Ilanit Stein 2013-05-21 09:23:58 EDT
Verified on sf16->sf-17 upgrade for 200M and 0 free disk space cases:

1. 

[root@istein-32 tmp]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg0-v_root
                      9.2G  8.5G  232M  98% /
tmpfs                 1.9G     0  1.9G   0% /dev/shm
/dev/vda1             485M   32M  428M   7% /boot
/dev/mapper/vg0-v_home
                      914M   18M  850M   2% /home
[root@istein-32 tmp]# rhevm-upgrade
Warning: available disk space at / (231 MB) is lower than the minimum requirement for the upgrade (1510 MB)
Not enough free space available for the upgrade operation.Stopping upgrade.
If you would like to perform an upgrade and ignore the space check,
run the upgrade with --no-space-check option
Error: Upgrade failed.
please check log at /var/log/ovirt-engine/ovirt-engine-upgrade_2013_05_21_04_17_16.log

2. 

[root@istein-32 tmp]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg0-v_root
                      9.2G  8.8G     0 100% /
tmpfs                 1.9G     0  1.9G   0% /dev/shm
/dev/vda1             485M   32M  428M   7% /boot
/dev/mapper/vg0-v_home
                      914M   18M  850M   2% /home
[root@istein-32 tmp]# yum update rhevm-setup
Loaded plugins: product-id, rhnplugin, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rhevm-setup.noarch 0:3.2.0-10.25.beta3.el6ev will be updated
---> Package rhevm-setup.noarch 0:3.2.0-10.26.rc.el6ev will be an update
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                 Arch                                               Version                                                          Repository                                                 Size
=============================================================================================================================================================================================================================================
Updating:
 rhevm-setup                                             noarch                                             3.2.0-10.26.rc.el6ev                                             rhevm-upgrade                                             170 k

Transaction Summary
=============================================================================================================================================================================================================================================
Upgrade       1 Package(s)

Total download size: 170 k
Is this ok [y/N]: y
Downloading Packages:


Error Downloading Packages:
  rhevm-setup-3.2.0-10.26.rc.el6ev.noarch: Insufficient space in download directory /var/cache/yum/x86_64/6Server/rhevm-upgrade/packages
    * free   0 
    * needed 170 k
Comment 19 Itamar Heim 2013-06-11 05:04:25 EDT
3.2 has been released
Comment 20 Itamar Heim 2013-06-11 05:04:25 EDT
3.2 has been released
Comment 21 Itamar Heim 2013-06-11 05:04:29 EDT
3.2 has been released
Comment 22 Itamar Heim 2013-06-11 05:04:48 EDT
3.2 has been released
Comment 23 Itamar Heim 2013-06-11 05:33:49 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.