Bug 885606
| Summary: | [installation] RHEVM Installation should check for sufficient free disk space before starting installation | ||||||
|---|---|---|---|---|---|---|---|
| Product: | Red Hat Enterprise Virtualization Manager | Reporter: | Gadi Ickowicz <gickowic> | ||||
| Component: | ovirt-engine-setup | Assignee: | Moran Goldboim <mgoldboi> | ||||
| Status: | CLOSED DUPLICATE | QA Contact: | David Botzer <dbotzer> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | high | ||||||
| Version: | 3.1.0 | CC: | bazulay, dyasny, iheim, lpeer, nlevinki, pstehlik, Rhev-m-bugs, sgrinber, yeylon, ykaul | ||||
| Target Milestone: | --- | ||||||
| Target Release: | 3.2.0 | ||||||
| Hardware: | All | ||||||
| OS: | Linux | ||||||
| Whiteboard: | integration | ||||||
| Fixed In Version: | Doc Type: | Bug Fix | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2013-02-12 11:01:54 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
*** This bug has been marked as a duplicate of bug 876482 *** |
Created attachment 660627 [details] installation logs Description of problem: rhevm-setup should check that there is enough free disk space before starting to run the installation and fail with an appropriate message if not enough disk space is detected Version-Release number of selected component (if applicable): rhevm-3.1.0-32.el6ev.noarch How reproducible: 100% Steps to Reproduce: 1. Run rhevm-setup on machine with not enough free disk space for DB creation Actual results: Installation fails during Creating Database without appropriate error message Expected results: Installation should not attempt to create DB on disk that does not have enough disk space Additional info: manually starting the postgress service gives the following result: [root@jenkins-vm-06 ~]# runuser -l postgres -c '/usr/bin/postmaster -p ''5432'' -D ''/var/lib/pgsql/data''' FATAL: could not write lock file "postmaster.pid": No space left on device