Bug 885606 - [installation] RHEVM Installation should check for sufficient free disk space before starting installation
[installation] RHEVM Installation should check for sufficient free disk space...
Status: CLOSED DUPLICATE of bug 876482
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
All Linux
high Severity high
: ---
: 3.2.0
Assigned To: Moran Goldboim
David Botzer
Depends On:
  Show dependency treegraph
Reported: 2012-12-10 03:26 EST by Gadi Ickowicz
Modified: 2014-08-21 21:41 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-12 06:01:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
installation logs (52.64 KB, text/x-log)
2012-12-10 03:26 EST, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2012-12-10 03:26:12 EST
Created attachment 660627 [details]
installation logs

Description of problem:
rhevm-setup should check that there is enough free disk space before starting to run the installation and fail with an appropriate message if not enough disk space is detected

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run rhevm-setup on machine with not enough free disk space for DB creation

Actual results:
Installation fails during Creating Database without appropriate error message

Expected results:
Installation should not attempt to create DB on disk that does not have enough disk space

Additional info:
manually starting the postgress service gives the following result:

[root@jenkins-vm-06 ~]# runuser -l postgres -c '/usr/bin/postmaster -p ''5432'' -D ''/var/lib/pgsql/data'''
FATAL:  could not write lock file "postmaster.pid": No space left on device
Comment 2 Moran Goldboim 2013-02-12 06:01:54 EST

*** This bug has been marked as a duplicate of bug 876482 ***

Note You need to log in before you can comment on or make changes to this bug.