Bug 876611 - Upgrade needs to ensure that /var/lib/pulp/journal/watchdog can be created.
Upgrade needs to ensure that /var/lib/pulp/journal/watchdog can be created.
Status: CLOSED WORKSFORME
Product: Pulp
Classification: Community
Component: rel-eng (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.0
Assigned To: Jeff Ortel
Preethi Thomas
: Triaged
Depends On:
Blocks: katello-v2-pulp 876673
  Show dependency treegraph
 
Reported: 2012-11-14 10:18 EST by Justin Sherrill
Modified: 2013-02-01 12:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 876673 (view as bug list)
Environment:
Last Closed: 2013-02-01 12:03:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-11-14 10:18:34 EST
Description of problem:

When i upgraded from a testing build to the newet beta, apache threw errors when starting because /var/lib/pulp/journal/watchdog/ was not created.

talking to jortel this is a possibility when upgrading from pulpv1 to pulpv2  so we need to make sure that the watchdog directory is created properly after upgrade. 


I'm not entirely sure of the circumstances of it not being crated, as two other developers were fine in the same scenario of upgrading to the beta.  The concern is to just verify that that directory is created normally by apache upon upgrade from pulpv1.
Comment 1 Jeff Ortel 2013-02-01 12:03:22 EST
This was not observed during v2 upgrade testing.

Note You need to log in before you can comment on or make changes to this bug.