Bug 876673 - Upgrade needs to ensure that /var/lib/pulp/journal/watchdog can be created.
Upgrade needs to ensure that /var/lib/pulp/journal/watchdog can be created.
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: rel-eng (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Ortel
Preethi Thomas
: Triaged
Depends On: 876611
Blocks: katello-v2-pulp
  Show dependency treegraph
 
Reported: 2012-11-14 12:16 EST by Preethi Thomas
Modified: 2012-11-27 12:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 876611
Environment:
Last Closed: 2012-11-27 12:56:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-11-14 12:16:45 EST
clone for master

+++ This bug was initially created as a clone of Bug #876611 +++

Description of problem:

When i upgraded from a testing build to the newet beta, apache threw errors when starting because /var/lib/pulp/journal/watchdog/ was not created.

talking to jortel this is a possibility when upgrading from pulpv1 to pulpv2  so we need to make sure that the watchdog directory is created properly after upgrade. 


I'm not entirely sure of the circumstances of it not being crated, as two other developers were fine in the same scenario of upgrading to the beta.  The concern is to just verify that that directory is created normally by apache upon upgrade from pulpv1.
Comment 1 Jay Dobies 2012-11-27 12:56:19 EST
Closing out the master version of this. It'll get merged into master post-2.0 and doesn't need to be separately tested.

Note You need to log in before you can comment on or make changes to this bug.