Bug 876655 - Lorax does not support building initramfs for fedup
Lorax does not support building initramfs for fedup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 869064 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-14 11:44 EST by Tim Flink
Modified: 2013-07-04 09:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:53:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-11-14 11:44:46 EST
In order to support upgrades over network, lorax needs to be able to build an initramfs which includes fedup modules.

Please update lorax to build an upgrade initramfs once the code is available.
Comment 1 Tim Flink 2012-11-14 11:46:59 EST
Proposed as a F18 beta blocker due to violation of the following F18 beta release criterion [1] as building the upgrade initramfs is required for network upgrades:

For each one of the release-blocking package sets ('minimal', and the package sets for each one of the release-blocking desktops), it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using any officially recommended upgrade mechanisms. The upgraded system must meet all release criteria.

[1] http://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 2 Kamil Páral 2012-11-14 12:45:19 EST
Discussed at 2012-11-14 blocker bug meeting. Accepted as a blocker:  This prevents fedup from doing network upgrades and violates the following F18 beta release criterion: "... it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed, using any officially recommended upgrade mechanisms. The upgraded system must meet all release criteria."
Comment 3 Adam Williamson 2012-11-20 02:03:06 EST
https://admin.fedoraproject.org/updates/FEDORA-2012-18603/lorax-18.22-2.fc18 claims to fix this: -> MODIFIED
Comment 4 Adam Williamson 2012-11-20 15:40:55 EST
Just me doing my Bodhi impression, nothing to see here, continue about your business...
Comment 5 Fedora Update System 2012-11-20 18:23:52 EST
lorax-18.22-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-18603/lorax-18.22-4.fc18
Comment 6 Tim Flink 2012-11-21 13:53:48 EST
Confirming that there are upgrade.img initramfs files built with F18 beta RC1.

I did a test upgrade with fedup on a F17 x86_64 Gnome desktop install, pointing --instrepo at the RC1 os/ directory (where the .treeinfo is).

The upgrade succeeded, this appears to have been fixed.
Comment 7 Fedora Update System 2012-11-23 02:53:40 EST
lorax-18.22-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Tim Flink 2012-11-28 23:27:20 EST
*** Bug 869064 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.