Bug 876688 - HA replication of propagated bindings can lead to incorrect configuration
HA replication of propagated bindings can lead to incorrect configuration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity unspecified
: 2.3
: ---
Assigned To: Chuck Rolke
MRG Quality Engineering
: OtherQA, Patch
Depends On:
Blocks: 698367 880360
  Show dependency treegraph
 
Reported: 2012-11-14 12:46 EST by Jason Dillaman
Modified: 2013-03-19 12:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.18-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 880360 (view as bug list)
Environment:
Last Closed: 2013-03-19 12:39:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quick patch to exlude propagated bindings from replication (13.84 KB, patch)
2012-11-14 13:13 EST, Jason Dillaman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4481 None None None Never

  None (edit)
Description Jason Dillaman 2012-11-14 12:46:12 EST
Description of problem:
When using dynamic federation between two independent HA broker clusters, it is possible under certain failover scenarios for the propagated bindings on the source broker to become out-of-sync with the true state of bindings on the destination broker.

Version-Release number of selected component (if applicable):
Qpid 0.18-9

How reproducible:
Often -- race condition between re-establishment of federated link and the deletion of a binding on the destination broker

Steps to Reproduce:
1. Start a stand-alone broker (route destination) and an HA broker (route source w/ primary and backup)
2. Configure a dynamic federated route between a destination broker and a source broker.  The dynamic federation needs to utilize an existing, non-auto-delete queue on the source broker.
3. Subscribe to an auto-delete queue on the destination broker and bind the auto-delete queue to the exchange configured for the dynamic federation
4. Kill the primary source broker
5. Kill the subscription to the auto-delete queue on the destination broker
6. Promote the backup source broker to primary
  
Actual results:
With the loss of the client subscription to the auto-delete queue, the binding will be removed.  If the binding is removed prior to the re-establishment of the federated link to the source broker, the unbind command will not propagate.  Since the backup source broker had previously replicated the propagated binding, the binding will incorrectly remain on the source broker.

Expected results:
Propagated bindings should not be replicated from the primary to backups since they are transient and will be recreated when the route is re-established.

Additional info:
Comment 1 Jason Dillaman 2012-11-14 13:13:54 EST
Created attachment 645040 [details]
Quick patch to exlude propagated bindings from replication
Comment 4 Alan Conway 2012-11-27 16:52:23 EST
Reviewed and approve of the fix 0.18-mrg-crolke-bz876688

Note You need to log in before you can comment on or make changes to this bug.