Bug 880360 - HA replication of propagated bindings can lead to incorrect configuration
HA replication of propagated bindings can lead to incorrect configuration
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity unspecified
: 3.0
: ---
Assigned To: Chuck Rolke
Irina Boverman
: OtherQA, Patch
Depends On: 876688
Blocks: 698367
  Show dependency treegraph
 
Reported: 2012-11-26 15:01 EST by Justin Ross
Modified: 2014-09-24 11:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.3
Doc Type: Bug Fix
Doc Text:
It was discovered that when using dynamic federation between two independent HA broker clusters, it was possible under certain failover scenarios for the propagated bindings on the source broker to become out-of-sync with the actual state of bindings on the destination broker. With the loss of the client subscription to the auto-delete queue, the binding was removed. If the binding was removed prior to the re-establishment of the federated link to the source broker, the unbind command did not propagate. Because the backup source broker had previously replicated the propagated binding, the binding incorrectly remained on the source broker. The fix prevents propagated bindings replicating from primary to back-up brokers. Transient bindings are recreated when the route is re-established and configurations remain synchronized.
Story Points: ---
Clone Of: 876688
Environment:
Last Closed: 2014-09-24 11:05:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 8 errata-xmlrpc 2014-09-24 11:05:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.