Bug 8767 - fdisk core dumps when adding partitions
Summary: fdisk core dumps when adding partitions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
: 9588 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-23 14:38 UTC by josef.chladek
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-04 21:30:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description josef.chladek 2000-01-23 14:38:52 UTC
i don't define all partitions while setup of rh
6.1, i just add them after finishing the
installation with fdisk. the problem is: as soon i
try to add new partitions, fdisk dumps a core:

Kommando (m f|r Hilfe): p
....
Kommando (m f|r Hilfe): n
Kommando  Aktion
   l      Logische Partition (5 oder grv_er)
   p      Primdre Partition (1-4)
l
Erster Zylinder (1311-2213) [Standardwert: 1311]:
Benutze den Standardwert 1311
Letzter Zylinder oder +Grv_e, +Grv_eK oder +Grv_eM
(1311-1438) [Standardwert: 1438]: +1000M
Segmentation fault (core dumped)

system is a hp netserver lpr with megaraid
controller.
tried this even on a "normal"-scsi system,
resulting in the same behaviour - all i get is a
core.
never had that problems before (5.0, 5.2, 6.0),
any suggestions

thanks
josef

Comment 1 Cristian Gafton 2000-02-17 23:35:59 UTC
derek, can you test this for me on the current beta?

Comment 2 Cristian Gafton 2000-03-04 21:28:59 UTC
*** Bug 9588 has been marked as a duplicate of this bug. ***

Comment 3 Cristian Gafton 2000-03-04 21:29:59 UTC
Fixed in the current devel tree


Note You need to log in before you can comment on or make changes to this bug.