Bug 876992 - maven-wagon: FTBFS - cyclic dependency in reactor
maven-wagon: FTBFS - cyclic dependency in reactor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-wagon (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
: 914177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-15 08:38 EST by Mikolaj Izdebski
Modified: 2013-03-05 11:32 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 11:32:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-11-15 08:38:00 EST
[ERROR] The projects in the reactor contain a cyclic reference: Edge between 'Vertex{label='org.apache.maven.wagon:wagon-ssh:1.0'}' and 'Vertex{label='org.apache.maven.wagon:wagon-ssh-common:1.0'}' introduces to cycle in the graph org.apache.maven.wagon:wagon-ssh-common:1.0 --> org.apache.maven.wagon:wagon-provider-api:1.0 --> org.apache.maven.wagon:wagon-ssh:1.0 --> org.apache.maven.wagon:wagon-ssh-common:1.0 -> [Help 1]

http://koji.fedoraproject.org/koji/taskinfo?taskID=4691693
Comment 1 Mikolaj Izdebski 2013-02-26 11:38:46 EST
*** Bug 914177 has been marked as a duplicate of this bug. ***
Comment 2 Mikolaj Izdebski 2013-03-04 02:24:46 EST
Fixed in maven-wagon-2.4-1
Comment 3 Mikolaj Izdebski 2013-03-05 11:32:27 EST
I believe that this bug is fixed in maven-wagon-2.4-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=399083

Note You need to log in before you can comment on or make changes to this bug.