Bug 877224 - [RFE] engine-setup should inform the user to install ovirt engine reports and DWH.
Summary: [RFE] engine-setup should inform the user to install ovirt engine reports and...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Lev Veyde
QA Contact: Karolína Hajná
URL:
Whiteboard:
Depends On: 911191 967351 1058013
Blocks: 976174 978165 978166 978167 978168
TreeView+ depends on / blocked
 
Reported: 2012-11-16 00:56 UTC by Bryan Yount
Modified: 2019-04-28 10:40 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, engine-setup notifies the user of the availability of the Reports and Data Warehouse components. These components are not required by all users, so are not installed by default; instead, the installer advertises their availability so that the user can choose whether or not to install them.
Clone Of:
: 976174 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:28:14 UTC
oVirt Team: Integration
sgrinber: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 38277 master MERGED packaging: setup: Inform the user about availability of DWH and Reports Never
Red Hat Knowledge Base (Solution) 143973 None None None Never

Description Bryan Yount 2012-11-16 00:56:27 UTC
Description of problem:
The rhevm-setup installer does not prompt the user to install rhevm-reports. This leads to customers perhaps not knowing about rhevm-reports until they need it at which point they will be starting with no data collected. It would be good if rhevm-setup prompted the user to install rhevm-reports and warned them about the additional memory requirements as well. As it stands now, if the user yum installs rhevm-reports on their own, there's no indication that additional memory may be required.

Version-Release number of selected component (if applicable):
3.1

How reproducible:
Very

Steps to Reproduce:
1. yum install rhevm
2. run 'rhevm-setup'
  
Actual results:
Install completes without asking the user to install the additional set of packages that comprises rhevm-reports

Expected results:
Installer should ask the user if they would like to install an additional component, rhevm-reports, and should warn them that additional system memory may be required.

Comment 8 RHEL Product and Program Management 2013-06-26 19:46:12 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 9 Alex Lourie 2013-08-26 22:07:28 UTC
I suggest we wait for the otopi based reports installer implementation.

Comment 10 Itamar Heim 2013-08-28 21:10:35 UTC
Alex - bug is not slated to 3.3 at this point, so is on the wait already. you can add a dependency on the otopi bug directly

Comment 11 Sandro Bonazzola 2014-02-13 14:43:24 UTC
Proposing this for 3.4.0 since all dependencies have been fixed.

Comment 12 Sandro Bonazzola 2014-02-13 14:51:49 UTC
Now that reports and DWH have been migrated to otopi, we can detect if dwh and reports plugin are there and if not output an informative message about the availability of DWH and reports.
Either if it's available or not we can tell the user about the additional memory requirements.
Then if missing ask the user to install them and run again setup in a second step or abort so the user can install missing packages and then tun setup again.

What we're just missing here is the text we have to output.
Yaniv can you detail additional requirements for the message?
I assume this message may be useful also on upstream, right?

Comment 14 Yaniv Lavi 2014-02-16 17:12:41 UTC
(In reply to Sandro Bonazzola from comment #12)
> Now that reports and DWH have been migrated to otopi, we can detect if dwh
> and reports plugin are there and if not output an informative message about
> the availability of DWH and reports.
> Either if it's available or not we can tell the user about the additional
> memory requirements.
> Then if missing ask the user to install them and run again setup in a second
> step or abort so the user can install missing packages and then tun setup
> again.
> 
> What we're just missing here is the text we have to output.
> Yaniv can you detail additional requirements for the message?
> I assume this message may be useful also on upstream, right?

I think this pretty much covers this. Output that this is optional and I would recommend checking that dwh & reports isn't installed remotely. checking lastSync in DWH for non default value and if the reports' redirect is present and non default.



Yaniv

Comment 15 Alon Bar-Lev 2014-02-16 17:15:03 UTC
(In reply to Yaniv Dary from comment #14)
> I would recommend checking that dwh & reports isn't installed remotely.

Do we support this configuration or this is in theory?

Comment 16 Yaniv Lavi 2014-02-16 17:49:36 UTC
(In reply to Alon Bar-Lev from comment #15)
> (In reply to Yaniv Dary from comment #14)
> > I would recommend checking that dwh & reports isn't installed remotely.
> 
> Do we support this configuration or this is in theory?

It will be in for 3.5 probably.


Yaniv

Comment 17 Alon Bar-Lev 2014-02-16 18:04:13 UTC
(In reply to Yaniv Dary from comment #16)
> (In reply to Alon Bar-Lev from comment #15)
> > (In reply to Yaniv Dary from comment #14)
> > > I would recommend checking that dwh & reports isn't installed remotely.
> > 
> > Do we support this configuration or this is in theory?
> 
> It will be in for 3.5 probably.

This bug is for 3.4

Comment 18 Yaniv Lavi 2014-02-16 18:44:24 UTC
(In reply to Alon Bar-Lev from comment #17)
> (In reply to Yaniv Dary from comment #16)
> > (In reply to Alon Bar-Lev from comment #15)
> > > (In reply to Yaniv Dary from comment #14)
> > > > I would recommend checking that dwh & reports isn't installed remotely.
> > > 
> > > Do we support this configuration or this is in theory?
> > 
> > It will be in for 3.5 probably.
> 
> This bug is for 3.4

I have no problem having this one way in 3.4 and another in 3.5.
I would want to save rewrite.

Comment 19 Sandro Bonazzola 2014-02-19 09:21:57 UTC
Yaniv, can you detail memory / disk requirements for DWH and reports?

Comment 20 Yaniv Lavi 2014-02-19 09:26:24 UTC
(In reply to Sandro Bonazzola from comment #19)
> Yaniv, can you detail memory / disk requirements for DWH and reports?

It is very hard to do since it is very dependent on the managed environment size.
We asked jasper for guidelines for this and they couldn't provide.

Comment 21 Einav Cohen 2014-06-02 17:58:01 UTC
removing UserExperience keyword - no user experience design advice is needed.

Comment 23 Sandro Bonazzola 2014-07-22 09:09:52 UTC
According to http://community-static.jaspersoft.com/sites/default/files/docs/jasperreports-server-install-guide.pdf 

 minimum requirements are:
 disk: 10GB free
 ram: 3GB

 recommended requirements are:
 disk: >= 40GB
 ram: >= 4GB

Let's use those as starting point.

Comment 26 Yaniv Lavi 2015-01-25 11:55:05 UTC
Re-scoping this issue:

Since user are able to install reports\dwh on separate server and this is the recommended installation path and since in the future we plan to provide reports and DWH via virtual appliance, we will not suggest to install these package locally.

The requirement here is to provide oVirt wiki link\docs to installation of reports and DWH and in the future recommend enabling the appliance from GUI.

Comment 27 Doron Fediuck 2015-02-17 15:12:38 UTC
(In reply to Yaniv Dary from comment #26)

> The requirement here is to provide oVirt wiki link\docs to installation of
> reports and DWH and in the future recommend enabling the appliance from GUI.

Do we currently have such links?
How do we make sure it's persistent / avoid hard-coding it into the installer?

Comment 29 Doron Fediuck 2015-02-17 16:15:44 UTC
Dynamic links cannot be in the code.
So either we have a general statement or find a mechanism to provide
something reliable that works even with no connection to the Internet,
as I expect many deployments are.

Comment 31 Yaniv Lavi 2015-02-19 16:17:53 UTC
We already provide links in other places in the code, please use the same method to add links to these docs.

Comment 33 Sandro Bonazzola 2015-02-25 10:33:07 UTC
Einav, can you advise on comment #32?

Didi: looks ok to me.

Comment 34 Einav Cohen 2015-02-25 23:15:08 UTC
(In reply to Sandro Bonazzola from comment #33)
> Einav, can you advise on comment #32?
> 

Adding Greg. 
The explanation regarding how the context-sensitive-help documentation-links work sounds correct to me (Greg should confirm). 
Also, the suggested solution to have the link hard-coded in the setup (preferably in some parameter/conf if possible, obviously) sounds OK.

Comment 35 Greg Sheremeta 2015-02-26 00:05:40 UTC
Didi explained it perfectly!

Comment 36 Karolína Hajná 2015-05-12 09:51:24 UTC
Verified on 3.6.0-0.0.master.20150510172322.git48679b7.el6

Comment 39 errata-xmlrpc 2016-03-09 20:28:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.