Bug 877304 - [ALL_LANG][SAM Web GUI] Unlocalized Login page and tooltips.
[ALL_LANG][SAM Web GUI] Unlocalized Login page and tooltips.
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Mike McCune
SAM QE List
: Translation
: 886724 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-16 03:29 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Unlocalized Login page tooltips and message (94.21 KB, image/png)
2012-11-16 03:30 EST, Lijun Li
no flags Details
Login messages are localized when login with local ja_JP firefox browser (144.79 KB, image/png)
2012-11-16 04:19 EST, Lijun Li
no flags Details

  None (edit)
Description Lijun Li 2012-11-16 03:29:26 EST
Description of problem:
Unlocalized Login page, tooltips and message.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Access Subscription Asset Manager using a web browser at the address https://[HOSTNAME or IP ADDRESS]/sam.
2. Move cursor over to your browser's tab - check the tooltips for the 'Subscription Asset Manager - Subscription Management ' tab.
3. Click on Forgotten Username or Password, check the 'Username Unknown' and 'Password Unknown' page:
4. Test unsuccessful login using wrong password, then wrong username, then succesful login.
  
Actual results:
Unlocalized Login page, tooltips and message.

Expected results:
After change the user locale, all the page, tooltips, message should be localized.

Additional info:
Comment 1 Lijun Li 2012-11-16 03:30:58 EST
Created attachment 646233 [details]
Unlocalized Login page tooltips and message
Comment 2 Lijun Li 2012-11-16 04:19:27 EST
Created attachment 646256 [details]
Login messages are localized when login with local ja_JP firefox browser
Comment 3 Satyabrata Maitra 2012-11-19 05:55:20 EST
Hi Robert

It is recommended to report a single bug for every locale, for the translation related issues for the respective locale.
Please do not file separate bugs for the same locale, with the translation issues in different pages of the same Web UI.
For Example, if you find several translation related issues in ja_JP locale, in SAM Web GUI, you should file a single bug for that, mentioning all the issues where you found untranslated strings in that locale. 
It is easier for the devel or language maintainers to find all the translation related issues (for a particular version of the component on a particular locale) in a single bug and resolve it.
So, for translation, for one component, one bug per language is the standard practice.
Comment 4 Lijun Li 2012-11-19 21:49:33 EST
(In reply to comment #3)
> Hi Robert
> 
> It is recommended to report a single bug for every locale, for the
> translation related issues for the respective locale.
> Please do not file separate bugs for the same locale, with the translation
> issues in different pages of the same Web UI.
> For Example, if you find several translation related issues in ja_JP locale,
> in SAM Web GUI, you should file a single bug for that, mentioning all the
> issues where you found untranslated strings in that locale. 
> It is easier for the devel or language maintainers to find all the
> translation related issues (for a particular version of the component on a
> particular locale) in a single bug and resolve it.
> So, for translation, for one component, one bug per language is the standard
> practice.

Thanks Satya, yup, I prefer to that file a bug for each components such as Login, User, Roles, Orgs, ... So that L10n team can save time to locate the strings and fix them soon.
Comment 5 Lijun Li 2012-11-19 21:51:46 EST
Note that the SAM Web GUI locale strings based on the browser locale & SAM Web GUI user locale.
Comment 6 Satyabrata Maitra 2012-11-21 01:56:29 EST
I do not know the relevance of your last comment. It is known that SAM Web GUI takes the browser locale by default and user can set their own locale, from the list appears after login, and also they can create new user with their preferred locale and login with that preferred credential to get their app to run on that locale.
But, it is still recommended as I discussed and informed you earlier, that one translation bug per locale, for one app to maintain.
And of course, for CLI, or command line translation issues, you need to file separate bug, even if the problem found is the same with the GUI one.
Comment 7 Lijun Li 2012-12-13 05:10:31 EST
*** Bug 886724 has been marked as a duplicate of this bug. ***
Comment 8 Jason E. Rist 2012-12-18 09:24:29 EST
c2d0a38e861b4a267cda606c295588f305c5d886
Comment 10 Bryan Kearney 2013-06-06 16:50:21 EDT
Moving all POST / MODIFIED bugs to ON_QA due to the new builds.
Comment 11 Bryan Kearney 2013-06-07 14:28:19 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.