Bug 877310 - [ALL_LANG][SAM Web GUI] Unlocalized 'About' and About page.
[ALL_LANG][SAM Web GUI] Unlocalized 'About' and About page.
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
: Translation, Triaged
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-16 03:40 EST by Lijun Li
Modified: 2013-10-01 06:53 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Strings on "About" page now passed through translation system.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:53:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Unlocalized 'About' and About page. (69.90 KB, image/png)
2012-11-16 03:42 EST, Lijun Li
no flags Details
Localized About page (73.33 KB, image/png)
2013-08-29 23:46 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description Lijun Li 2012-11-16 03:40:57 EST
Description of problem:
Unlocalized 'About' and About page.

Version-Release number of selected component (if applicable):
katello-headpin-all-1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Login, test links found at the footer of the login page: Click on the Subscription Asset Manager Version: 1.2.5-1h.el6_3 link to check the About page. 
2. OR Move cursor over the Administer menu at the top right corner and click on About.

  
Actual results:
Unlocalized 'About' and About page.

Expected results:
'About' sub menu and About page should be localized.

Additional info:
Comment 1 Lijun Li 2012-11-16 03:42:20 EST
Created attachment 646245 [details]
Unlocalized 'About' and About page.
Comment 2 Hedda Peters 2012-12-12 18:13:47 EST
Partly untranslated for de-DE: "Installed Packages", "Application", "Authentication"... are untranslated

Some strings are translated: "About", "To submit a bug report...", "System Information"... are translated
Comment 3 Francesco Valente 2012-12-12 18:17:56 EST
Same for it-IT.
Comment 4 Noriko Mizumoto 2012-12-12 20:09:57 EST
Same for ja-JP.
'Application', 'Authentication', 'Directory', 'Ruby', 'Version' and '環境' all appear as Parameter for System Info. Not sure those parameters to be translated or to be left in English.
Comment 5 Sam Friedmann 2012-12-12 20:23:02 EST
In French, only "Installed Packages", "Authentication" and "Directory" are untranslated, the rest is translated.
Comment 7 sthirugn@redhat.com 2012-12-17 15:16:27 EST
Same for French - 
Issue added from an other BZ https://bugzilla.redhat.com/show_bug.cgi?id=879170
Comment 8 Tazim Kolhar 2012-12-31 02:38:19 EST
FAILED QA :

# rpm -qa | grep katello
katello-glue-candlepin-1.2.1-10h.el6_3.noarch
katello-cli-common-1.2.1-11h.el6_3.noarch
katello-headpin-1.2.1-10h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-cli-1.2.1-11h.el6_3.noarch
katello-configure-1.2.3-1h.el6_3.noarch
katello-common-1.2.1-10h.el6_3.noarch
katello-headpin-all-1.2.1-10h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch


The translation in the 'About Page' is failing for :
[de,ja, es, fr, it, ko, pt-BR, gu, hi, mr, or, ru, te, pa, kn, bn, ta, zh-CN, zh-TW] 

failing for ALL_LANGUAGE
Comment 9 Bryan Kearney 2013-08-28 12:57:49 EDT
1.4.3-11-sat has the latest strings, so these bugs shuld be fixed.
Comment 10 sthirugn@redhat.com 2013-08-29 23:45:28 EDT
VERIFIED. (screenshot attached)

Version Tested:
* candlepin-0.8.24-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.24-1.el6sam.noarch
* candlepin-tomcat6-0.8.24-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-9.el6sat.noarch
* katello-cli-common-1.4.3-9.el6sat.noarch
* katello-common-1.4.3-11.el6sam_splice.noarch
* katello-configure-1.4.4-3.el6sat.noarch
* katello-glue-candlepin-1.4.3-11.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-11.el6sam_splice.noarch
* katello-headpin-1.4.3-11.el6sam_splice.noarch
* katello-headpin-all-1.4.3-11.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 11 sthirugn@redhat.com 2013-08-29 23:46:04 EDT
Created attachment 791995 [details]
Localized About page
Comment 13 errata-xmlrpc 2013-10-01 06:53:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.