This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 877467 - elasticsearch upgrade step needed, either in docs or in katello-upgrade
elasticsearch upgrade step needed, either in docs or in katello-upgrade
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: Docs Release Notes (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Eliska Slobodova
Og Maciel
:
Depends On:
Blocks: sam12-tracker 878075
  Show dependency treegraph
 
Reported: 2012-11-16 10:41 EST by Tom McKay
Modified: 2014-10-04 12:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Add this to the upgrade steps: During the Katello upgrade we need to upgrade Elasticsearch from 0.18 to 0.19. It is necessary to flush indexes before the yum upgrade. When the 0.19 is started for the first time it tries to convert all the DB in new format so the old indexes wouldn't match. Note: During the DB conversion the backup is created so it is possible to revert the DB back to 0.18 format. The recommended steps are as follows: After stopping the katello instance according the generic instructions and before yum upgrade start Elasticsearch service elasticsearch start Flush indexes curl host:9200/_flush Stop Elasticsearch service elasticsearch stop For some more info about ES upgrade see ​ES release notes [http://www.elasticsearch.org/download/2012/10/23/0.19.11.html]
Story Points: ---
Clone Of:
: 878075 (view as bug list)
Environment:
Last Closed: 2013-02-25 11:17:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-11-16 10:41:45 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom McKay 2012-11-16 10:44:00 EST
https://fedorahosted.org/katello/wiki/Upgrade
Comment 2 Martin Bacovsky 2012-12-13 10:15:44 EST
The description of what needs to by done manually during upgrade is in the first paragraph https://fedorahosted.org/katello/wiki/Upgrade#katelloupgradefrom1.1to1.2

I'm not sure what to do with the content to get it to the docs.
Changing the component to doc-Release_Notes
Comment 3 Bryan Kearney 2013-01-15 11:54:43 EST
Adding PM Ack for doc chnage only.
Comment 4 Eliska Slobodova 2013-01-18 09:25:32 EST
I updated the Release Notes book with the complete description (the individual steps are also mentioned in the Installation Guide which is linked to from the Release Notes).

Please review the chapter in the updated book and let me know what you think:

http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Subscription_Asset_Manager/1.2/html-single/Release_Notes/index.html#installation-and-upgrading

Thanks!
Comment 5 Og Maciel 2013-01-18 09:42:47 EST
Hi Eliska, I checked the changes and there's one minor change we should make. Turns out I was performing this task (upgrade) yesterday and when flushing the elasticsearch index, instead of using curl host:9200/_flush you should use curl localhost:9200/_flush (localhost instead of host). Thanks in advance.
Comment 6 Eliska Slobodova 2013-01-18 09:57:08 EST
Alright, fixed. The updated book should appear shortly.
Thank you.
Comment 8 Scott Lewis 2013-01-21 10:41:01 EST
Removed blocker flag as changes made in Install Guide and Release Notes
Comment 9 Og Maciel 2013-01-23 14:28:49 EST
Hey Dan, this looks good to me, so I'm going to flag it as VERIFIED. I wasn't sure if you wanted to handle it or not, so I hope this is ok. :)
Comment 10 Eliska Slobodova 2013-02-25 11:17:21 EST
Closing; SAM 1.2 Release Notes are out now:
https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Subscription_Asset_Manager/1.2/html-single/Release_Notes/index.html

Note You need to log in before you can comment on or make changes to this bug.