Bug 877586 - System Set Configuration Channel Subscription Does not Allow Ranking
System Set Configuration Channel Subscription Does not Allow Ranking
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2012-11-16 19:47 EST by Kevin Stange
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Stange 2012-11-16 19:47:07 EST
Description of problem:

When I attempt to subscribe a system set to one or more configuration channels, the "Step 2: Rank Channels for Subscription." page does not list any channels to allow me to rank them.  The priority options (Subscribe With Lowest Priority, Subscribe With Highest Priority, Replace Existing Subscriptions) have no apparent effect either.

The channels are added to the subscription list, but they are sorted according to their ccid numbers, as best I can tell, no matter which order I add them.  I tried adding my preferred channel first and last, but it still ranks the one with the lower ID number as rank 1.

Version-Release number of selected component (if applicable):

spacewalk-java-1.8.180-1.el6.noarch

How reproducible:

100% reproducible

Steps to Reproduce:
1. Add two configuration channels
2. Create a system set of two or more systems
3. Click "Manage" > "Manage systems' config channel subscriptions"
4. Select two channels or select one channel and repeat steps 3 - 5 for 2 different channels.
5. Note that step 2 has no options in the list box, select any radio button and continue.
6. Go to one of the systems > Configuration > Manage Configuration Channels
7. Note the ranks of the channels, always the same.
  
Actual results:

The ranks of the channels will always be sorted by CCID.

Expected results:

The UI should allow ranking the channels at step 2 and should honor the radio button selection.

Additional info:

If I add the channels manually to a system, or rank them later, I can do so properly, but only with one system at a time.
Comment 1 Tomas Lestach 2013-02-08 06:08:22 EST
This was resolved within Bug 868884. Moving to MODIFIED.
Comment 2 Stephen Herr 2013-03-01 12:06:43 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 3 Stephen Herr 2013-03-06 13:34:04 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.