Bug 877961 - [RHS-C] Volume Advanced Details feature is not displaying any brick details
[RHS-C] Volume Advanced Details feature is not displaying any brick details
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
All All
high Severity high
: ---
: ---
Assigned To: Shubhendu Tripathi
Prasanth
:
Depends On: 888752 902214
Blocks: 850446 918453
  Show dependency treegraph
 
Reported: 2012-11-19 05:34 EST by Prasanth
Modified: 2013-09-23 18:26 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 918453 (view as bug list)
Environment:
Brick Details General Clients Memory Statistics Memory Pools Brick
Last Closed: 2013-09-23 18:26:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
brick_details_pop-up (104.59 KB, image/png)
2012-11-19 05:34 EST, Prasanth
no flags Details
engine.log (1.54 MB, text/x-log)
2012-11-19 05:39 EST, Prasanth
no flags Details
Screen Shot - QA9 (79.88 KB, image/png)
2013-04-01 15:46 EDT, Matt Mahoney
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12979 None None None Never

  None (edit)
Description Prasanth 2012-11-19 05:34:43 EST
Created attachment 647671 [details]
brick_details_pop-up

Description of problem:

Volume Advanced Details feature in the latest RHS-C QE drop is not working as documented in http://wiki.ovirt.org/wiki/Features/GlusterVolumeAdvancedDetails. It currently displays a pop-up screen with empty-contents.

Version-Release number of selected component (if applicable):

rhsc-2.1-qa18.el6ev.noarch
glusterfs-3.4.0qa2-1.el6rhs.x86_64


How reproducible: Always


Steps to Reproduce:

1. Create a Volume
2. Select the volume and click on the sub-tab, Bricks
3. Now, select a server and click on "Advanced Details".
4. A "Brick Details" pop-up window opens and displays a blank-screen.

  
Actual results: A pop-up window opens with empty contents.


Expected results: It should show the advanced details about a particular brick.


Additional info: This page cannot be closed with an "Esc" button or anything but gets closed only after reloading the current page.


Screen-shot and logs attached
Comment 1 Prasanth 2012-11-19 05:39:34 EST
Created attachment 647675 [details]
engine.log
Comment 3 Kanagaraj 2012-11-19 23:59:28 EST
This is due to the change in 'gluster volume status <volume-name> --xml' output of gluster CLI in glusterfs-3.4.0qa2-1.el6rhs.x86_64. 

This will be fixed in VDSM.
Comment 4 Shireesh 2012-11-20 02:32:36 EST
Looks like the output format of 'gluster volume status <volume-name> --xml' has changed, resulting in this issue.

An immediate work-around is to use the virt-* release of glusterfs on the storage nodes.

vdsm will be enhanced to take care of the changed format in the next qa release.
Comment 5 Bala.FA 2012-11-20 04:34:32 EST
Patch is available in upstream at http://gerrit.ovirt.org/#/c/9323/
Comment 6 Bala.FA 2012-11-29 04:02:18 EST
Patch submitted at https://code.engineering.redhat.com/gerrit/1712
Comment 7 Shireesh 2012-12-20 02:48:01 EST
Proper functioning of this feature depends on the glusterfs Bug 888752
Comment 8 Bala.FA 2012-12-20 07:49:08 EST
Current QE drop has this fix
Comment 9 Shireesh 2012-12-20 08:51:50 EST
No, just this fix won't do. It depends on a more serious bug 888752 in glusterfs
Comment 10 Dustin Tsang 2013-02-22 10:42:28 EST
Still an issue in rhsc-qa6.

error message displayed  on the advanced brick modal is "Error in fetching the brick details, please try again"

workaround
----------
It will eventually display the advanced brick details after closing the "modal" and reopening the modal multiple times.

logs
----
empty /var/log/ovirt-engine/engine.log.

Versions
---------
rhsc-2.1.0-0.qa6.el6rhs
glusterfs-server-3.4.0qa8-1.el6rhs.x86_64
Comment 11 Shireesh 2013-03-08 05:29:21 EST
Since the glusterfs bug is taking too long to resolve, I'll probably implement a work-around in rhs-c engine to execute the command on the same machine where the brick resides.
Comment 12 Matt Mahoney 2013-04-01 15:45:38 EDT
Bricks Advanced Details not displaying in QA9. Does not matter if bricks are Up or Down.
Comment 13 Matt Mahoney 2013-04-01 15:46:13 EDT
Created attachment 730414 [details]
Screen Shot - QA9
Comment 14 Shireesh 2013-04-02 02:32:37 EDT
Are you getting a pop-up screen with empty contents as mentioned in description of this bug, or some other problem?

Please provide 
a) screen-shot of the advanced details screen
b) engine logs
c) vdsm logs from the server where the brick resides. (Choose a brick which is UP, and is still not displaying the advanced details)
Comment 15 Matt Mahoney 2013-04-03 11:09:33 EDT
Verified working in QA9.
Comment 17 Scott Haines 2013-09-23 18:26:04 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.