Bug 878275 - Breadcrumb navigation in workspace should separate project version and locale
Breadcrumb navigation in workspace should separate project version and locale
Status: CLOSED DUPLICATE of bug 872038
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 21:16 EST by Hedda Peters
Modified: 2012-11-20 01:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 01:30:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-11-19 21:16:31 EST
Description of problem:
The breadcrumb naviation in the workspace shows only one combined step/link for the version of a project and the locale selected (Screenshot 1). I suggest to make this two separate steps/links, to make it consistent with the actual navigation process and to make it easier to go back to language overview.


Steps to Reproduce:
1. Open project page (e.g. CloudForms) 
2. Select product version (e.g. 1.1) 
3. Select language (e.g. de-DE) - document list appears, you can start translating away.

- Now, in order to go back to language overview, e.g. to check own progress compared to other languages...

Actual results:
... you need to click on cloudforms_installation_guide link in breadcrumbs navigation, which drops you at the project level where you need to select the project version again, before viewing the language list.


Expected results:
...you should be able to click on a link 1.1 in the breadcrumbs navigation, which drops you at the language overview.

Additional information:
Strangely enough, if you first click on this combined link 1.1 [de], on the resulting page there is a breadcrumb navigation that does indeed have those two steps separate. (Screenshot 2)
Comment 3 Alex Eng 2012-11-20 01:30:27 EST

*** This bug has been marked as a duplicate of bug 872038 ***

Note You need to log in before you can comment on or make changes to this bug.