Bug 878300 - Include configuring a datasource for EAP6
Include configuring a datasource for EAP6
Status: CLOSED DUPLICATE of bug 888669
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Documentation (Show other bugs)
BRMS 5.3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: lcarlon
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-19 23:08 EST by lcarlon
Modified: 2013-03-05 23:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 23:45:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description lcarlon 2012-11-19 23:08:14 EST
Installing BRMS 5.3.1 to EAP6 requires the default data must be changed. Details need to be included in the BRMS admin guide.
Comment 2 Petr Široký 2012-11-27 05:54:57 EST
Hi Lee,

just a few comments:

 - typo in procedure 2.4 step 1: there should be jboss-eap-6.0/modules/org/mysql/ instead of jboss-eap-6.0/modules.org/mysql/ (slash vs dot)

 - 2.4.2: instead of downloading latest jdbc driver, users should download driver corresponding to the database version they have chosen (e.g. postresql 8 vs postgresql 9)

 - 2.4.5: badly formatted XML listing; drivers section contains both h2 and postgressql, I am not sure if the h2 should be there
  - 2.4.5: missing slash between 'standalone' and 'configuration'

 - 2.4.6 and 2.4.7: inconsistencies in datasource name, brmsDS should be used everywhere instead of brms or DefaultDS.
 
 - the datasource name should be probably prefixed with java:jboss/datasources (e.g. java:jboss/datasources/brmsDS), but I need to verify this.
Comment 3 lcarlon 2012-11-28 01:00:32 EST
Hi Petr.

typo in 2.4 step 1 fixed. 

2.4.2, Fixed (Right, I was thinking latest for their version, but you're absolutely correct, your way gets the point across clearer).

I follow up on the h2 and postgresql issue. I did fix the missing slash though.

Inconsistencies with the db name have been fixed.

I'll post an updated when I have the h2 and postgresql info.
Comment 4 lcarlon 2012-11-28 21:31:49 EST
The h2 driver is not required. I have removed references to it from the example.

I'll post a link as soon as the updated doc is on the internal stage and available for review.

thanks
Lee
Comment 6 Petr Široký 2012-11-29 04:55:11 EST
Hi Lee,

thanks for quick response and fix! I just read the docs again and found few more things that probably need fixing (I am sorry I did not notice some of them the first time):

2.4.3: typo: create -> Create

2.4.7: "and the hbm2ddl.auto value to create:"; there should be "...value to update", right?

2.4.7, 2.4.8: as I mentioned above I believe datasource references should have the prefix "java:/jboss/datasources"(e.g. java:/brmsDS -> java:jboss/datasources/brmsDS)

Also regarding the overall datasource configuration, shouldn't we 'teach' users to use the tools distributed with EAP to setup the datasource (CLI or GUI tools) instead of editing the configuration file directly?
Comment 7 lcarlon 2012-11-29 20:23:57 EST
Hi Petr,

Likewise, thank you.

2.4.3 typo fixed.

2.4.7 bug 854612, comment 14 states that we should be using create-drop or create, and then remove the functionality. I've updated the procedure and added a note to explain the situation.

2.4.7, 2.4.8 updated, sorry I missed that.

Regarding datasource configuration. Possibly, yes, though it is out of scope for this document now.

I'll post a link to the updated doc as soon as it is live on the doc stage.

Thanks!
Lee
Comment 9 Petr Široký 2012-11-30 05:04:09 EST
Datasource JNDI name should be java:jboss/datasources/brmsDS instead of java:/jboss/datasources/brmsDS (note the slash between java: and jboss). This is my fault, typo got into my previous comment.
Comment 10 lcarlon 2012-12-02 18:57:58 EST
(In reply to comment #9)
> Datasource JNDI name should be java:jboss/datasources/brmsDS instead of
> java:/jboss/datasources/brmsDS (note the slash between java: and jboss).
> This is my fault, typo got into my previous comment.

No, I should have picked it up.

Fixed. I'll post a link as soon as it is live on the internal docs stage.

- Lee
Comment 12 lcarlon 2013-03-05 23:45:54 EST

*** This bug has been marked as a duplicate of bug 888669 ***

Note You need to log in before you can comment on or make changes to this bug.