Bug 87855 - Adding applications doesn't handle dependencies properly.
Adding applications doesn't handle dependencies properly.
Status: CLOSED DUPLICATE of bug 83485
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 01:43 EST by J.B. Nicholson-Owens
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.B. Nicholson-Owens 2003-04-03 01:43:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I started up the program, entered the root password, and chose to add a number
of packages and package categories.  I was told I couldn't install what I wanted
until I installed some other packages first.  Why didn't the installer app just
take care of these for me (possibly saying it would also install these other
packages)?

Version-Release number of selected component (if applicable):
1.1.8-1

How reproducible:
I can reproduce this every time.

Steps to Reproduce:
1. Install RH9.0 destroying all partitions.  Install the default "workstation"
set of apps.
2. Log in, run System Settings->Add/Remove Applications. (if necessary, input
root password when prompted)
3. Scroll down to development and turn on development tools, X software
development, and GNOME software development sets.  Don't modify the sets, just
take them as they are.
4. Click Update to install the applications in each set.

Actual Results:  The following packages could not be found on your system. 
Installation cannot continue until they are installed.

Unlocatable package    Required by
---------------------- ---------------
krb5-libs = 1.2.7-10   krb5-devel
openssl = 0.9.7a-2     openssl-devel

Expected Results:  The app should never have produced such a message.  All the
apps you can install with this installer app are RH9.0 apps.  So, RH ostensibly
checked them and shipped apps that have only dependencies that can be satisfied
with other packages from RH9.0.

Additional info:

I don't see how a novice user would deal with such a message should this come up
for something novices would be likely to run.  I think it would be far more
useful to determine what the unsatisfied dependencies are, install them, and let
the user move on with using the system.

I installed Red Hat 9.0 instructing the installer to wipe out all partitions on
the hard disk, so this should be an install from (nearly) scratch.  I also ran
the up2date program to update the installation prior to attempting to install
the dev tools listed above.  I have deleted no packages and I have installed no
packages except for those I tried to install through the redhat-config-packages
GUI and those I successfully installed with the up2date program.
Comment 1 Nathan Nichols 2003-04-03 03:49:53 EST
I'm running into the same issue.  In my case, the dependencies are there, but
the package utility isn't finding them or isn't sorting through them correctly.

For example, I attempted to install the telnet-server.  I was presented with a
dialog saying that the xinetd dependency must be satistfied first.

Jumping to command line, "rpm -qa | grep xinetd" reports:
xinetd-2.3.10-6

I was able to insert disc 3 and install the telnet-server RPM package manually
using rpm.
Comment 2 Jeremy Katz 2003-04-08 20:09:36 EDT

*** This bug has been marked as a duplicate of 83485 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.