Bug 878740 - Screensaver regression: have to use mouse before unlocking
Screensaver regression: have to use mouse before unlocking
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 878742 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 00:48 EST by Amit Shah
Modified: 2012-12-13 03:36 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 03:36:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2012-11-21 00:48:12 EST
Description of problem:

On earlier gnome3 versions, whenever I returned to the laptop when the screen was locked, I could just press any key and type the password / swipe finger to unlock.  On F18, I have to reach out to the mouse and use it to slide the curtain up before I can unlock the screensaver.

This is a huge usability regression in my workflow.  Please enable some keystroke (like Esc) or provide a way to disable the curtain.
Comment 1 Amit Shah 2012-11-21 00:59:25 EST
*** Bug 878742 has been marked as a duplicate of this bug. ***
Comment 2 Amit Shah 2012-11-23 05:42:04 EST
I just noticed that 'Esc' works after the animation (up arrows) is completed.  The mouse too refuses to move till the animation is complete.

Both, Esc as well as the mouse should be enabled as soon as the display is active, not after the animation is complete.
Comment 3 Amit Shah 2012-11-26 04:57:55 EST
This also causes a much more serious bug, see bug 878736
Comment 4 Amit Shah 2012-12-13 03:36:41 EST
Looks like this happened due to bug 878736, so closing this.

Note You need to log in before you can comment on or make changes to this bug.