Bug 878763 - [abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:963:_getFile:NoMoreMirrorsRepoError: failure: repodata/repomd.xml from fedora-16-i386: [Errno 256] No more mirrors to try.
[abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:963:_getFile:NoMoreMirrorsRepoErro...
Status: CLOSED DUPLICATE of bug 816556
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:f9028d7646e85c2aaf8cb3d458f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-21 02:53 EST by kuboode
Modified: 2012-11-21 04:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-21 04:21:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: executable (18 bytes, text/plain)
2012-11-21 02:53 EST, kuboode
no flags Details
File: dso_list (24 bytes, text/plain)
2012-11-21 02:53 EST, kuboode
no flags Details
File: environ (3.09 KB, text/plain)
2012-11-21 02:53 EST, kuboode
no flags Details
File: smolt_data (2.77 KB, text/plain)
2012-11-21 02:53 EST, kuboode
no flags Details
File: core_backtrace (2.02 KB, text/plain)
2012-11-21 02:53 EST, kuboode
no flags Details

  None (edit)
Description kuboode 2012-11-21 02:53:18 EST
Description of problem:
al escribir en terminal yum list nombre de paquete

Version-Release number of selected component:
yum-utils-1.1.31-4.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python -tt /usr/bin/repoquery --repofrompath=fedora-16-i386,http://download.fedoraproject.org/pub/fedora/linux/development/16/i386/os/ --repoid=fedora-16-i386 --qf %{NAME} --whatrequires hal hal-devel hal-info hal-libs hal-storage-addon
kernel:         3.6.6-1.fc17.i686

backtrace:
:yumRepo.py:963:_getFile:NoMoreMirrorsRepoError: failure: repodata/repomd.xml from fedora-16-i386: [Errno 256] No more mirrors to try.
:
:Traceback (most recent call last):
:  File "/usr/bin/repoquery", line 1510, in <module>
:    main(sys.argv)
:  File "/usr/bin/repoquery", line 1504, in main
:    repoq.runQuery(regexs)
:  File "/usr/bin/repoquery", line 988, in runQuery
:    for p in self.doQuery(oper, prco):
:  File "/usr/bin/repoquery", line 1027, in doQuery
:    return getattr(self, "fmt_%s" % method)(*args, **kw)
:  File "/usr/bin/repoquery", line 1066, in fmt_whatrequires
:    require_recursive(name)
:  File "/usr/bin/repoquery", line 1051, in require_recursive
:    for pkg in self.returnByName(name):
:  File "/usr/bin/repoquery", line 839, in returnByName
:    pkgs = self.returnPkgList(patterns=[name])
:  File "/usr/bin/repoquery", line 856, in returnPkgList
:    pkgs = self.pkgSack.returnNewestByNameArch(**kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 348, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 184, in populate
:    if self._check_db_version(repo, mydbtype):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 275, in _check_db_version
:    return repo._check_db_version(mdtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1394, in _check_db_version
:    repoXML = self.repoXML
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1580, in <lambda>
:    repoXML = property(fget=lambda self: self._getRepoXML(),
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1576, in _getRepoXML
:    self._loadRepoXML(text=self.ui_id)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1567, in _loadRepoXML
:    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1541, in _groupLoadRepoXML
:    if self._commonLoadRepoXML(text):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1365, in _commonLoadRepoXML
:    result = self._getFileRepoXML(local, text)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1143, in _getFileRepoXML
:    size=102400) # setting max size as 100K
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 963, in _getFile
:    raise Errors.NoMoreMirrorsRepoError(errstr, errors)
:NoMoreMirrorsRepoError: failure: repodata/repomd.xml from fedora-16-i386: [Errno 256] No more mirrors to try.
:
:Local variables in innermost frame:
:relative: 'repodata/repomd.xml'
:errors: None
:e: URLGrabError(256, 'No more mirrors to try.')
:start: None
:dirstat: posix.statvfs_result(f_bsize=4096, f_frsize=4096, f_blocks=8845226L, f_bfree=4764478L, f_bavail=4674639L, f_files=2252800L, f_ffree=1942053L, f_favail=1942053L, f_flag=4096, f_namemax=255)
:text: 'fedora-16-i386'
:self: <yum.yumRepo.YumRepository object at 0x9defb2c>
:cache: True
:reget: None
:avail: 19147321344L
:headers: ()
:checkfunc: (<bound method YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0x9defb2c>>, (), {})
:errstr: 'failure: repodata/repomd.xml from fedora-16-i386: [Errno 256] No more mirrors to try.'
:copy_local: 1
:kwargs: {}
:url: None
:end: None
:local: '/var/tmp/yum-devo-_Ov2Em/i386/17/fedora-16-i386/repomdxUk8kwtmp.xml'
:size: 102400
Comment 1 kuboode 2012-11-21 02:53:44 EST
Created attachment 649089 [details]
File: executable
Comment 2 kuboode 2012-11-21 02:53:48 EST
Created attachment 649090 [details]
File: dso_list
Comment 3 kuboode 2012-11-21 02:53:52 EST
Created attachment 649091 [details]
File: environ
Comment 4 kuboode 2012-11-21 02:53:54 EST
Created attachment 649092 [details]
File: smolt_data
Comment 5 kuboode 2012-11-21 02:53:58 EST
Created attachment 649093 [details]
File: core_backtrace
Comment 6 Zdeněk Pavlas 2012-11-21 04:21:22 EST

*** This bug has been marked as a duplicate of bug 816556 ***

Note You need to log in before you can comment on or make changes to this bug.