Bug 879151 - [ALL_LANG][SAM CLI] Unlocalized strings for headpin module
[ALL_LANG][SAM CLI] Unlocalized strings for headpin module
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 886764 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-22 03:29 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-22 03:29:12 EST
Description of problem:
Unlocalized strings for headpin module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
[root@i18nsamtest ~]# headpin --help
Usage:  headpin <options> <command>
^^^^^^^^^^^^^^^^Unlocalized
Supported Commands:
^^^^^Unlocalized
	activation_key Katello サーバーのアクティベーションキーに固有の動作
	architecture   Architecture specific actions in the katello server
                       ^^^^^^^^^^^^^^^^Unlocalized
	client         Katello サーバーのクライアントに固有の動作
	config_template config template specific actions in the katello server
                       ^^^^^^^^^^^^^^^^Unlocalized
	domain         domain specific actions in the katello server
                       ^^^^^^^^^^^^^^^^Unlocalized
	environment    Katello サーバーの環境に固有の動作
	org            Katello サーバーの組織に固有の動作
	permission     permission specific actions in the katello server
                       ^^^^^^^^^^^^^^^^Unlocalized
	ping           Katello サーバーのステータスを取得
	product        Katello サーバーで製品に固有の動作
	provider       Katello サーバーのプロバイダーに固有の動作
	shell          シェルとして cli を実行
	system         Katello サーバーのシステムに固有の動作
	user           Katello サーバーでユーザーに固有の動作
	user_role      katello サーバー内でのユーザーロール固有の動作
	version        katello サーバーのバージョンを取得

Options:
^^^^^^Unlocalized
  -h, --help            show this help message and exit
                       ^^^^^^^^^^^^^^^^Unlocalized
  -v, --version         バージョン情報を表示します
  -d, --debug           send debug information into logs
                       ^^^^^^^^^^^^^^^^Unlocalized
  Katello ユーザーアカウントの資格情報:
    -u USERNAME, --username=USERNAME
                        アカウントのユーザー名
    -p PASSWORD, --password=PASSWORD
                        アカウントのパスワード

  Katello サーバー情報:
    --host=HOST         Katello サーバーのホスト名 (デフォルト: localhost.localdomain)

[root@i18nsamtest ~]# headpin -test
...
headpin: error: no such option: -t
^^^^^^^^^^^^^^^^Unlocalized
[root@i18nsamtest ~]# headpin -u
...
headpin: error: -u option requires an argument
^^^^^^^^^^^^^^^^Unlocalize

(wrong username/password)
[root@i18nsamtest ~]# headpin -u admin -p admi -v
Invalid credentials
^^^^^^^^Unlocalize

Actual results:
Unlocalized strings for headpin module

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:48 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Hedda Peters 2012-12-13 00:54:01 EST
Exactly the same outcome for de-DE.

Currently all languages are at least 95% translated on Zanata, and the remaining untranslated strings are not the unlocalized ones mentioned above.
Comment 3 Noriko Mizumoto 2012-12-13 01:19:51 EST
confirmed for ja-JP.
The strings not localized and reported in this bug have all translated on zanata.
Comment 4 Lijun Li 2012-12-13 05:28:12 EST
*** Bug 886764 has been marked as a duplicate of this bug. ***
Comment 5 Eunju, Kim 2012-12-13 17:47:29 EST
confirmed for ko-KR.
Comment 6 Sam Friedmann 2012-12-13 19:56:43 EST
confirmed for fr-FR.
Comment 7 Tom McKay 2012-12-18 09:12:12 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 9 Bryan Kearney 2013-06-07 14:19:51 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 10 Bryan Kearney 2013-06-07 14:28:09 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.