Bug 879174 - [ALL_LANG][SAM CLI] Unlocalized strings for product module.
[ALL_LANG][SAM CLI] Unlocalized strings for product module.
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 886772 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-22 04:30 EST by Lijun Li
Modified: 2013-06-07 14:29 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:29:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-22 04:30:02 EST
Description of problem:
Unlocalized strings for product module.

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin product -h
Usage:  headpin <options> product <command>
Supported Commands:
	list           既知の製品を一覧表示

Options:
  -h, --help  show this help message and exit
              ^^^^^^^^^^^Unlocalized
[root@i18nsamtest ~]# headpin -u admin -p admin product list
Usage:  headpin <options> product list <options>

headpin: error: オプション --org は必須です: --help を参照してください
         ^^^^^^^Unlocalized
[root@i18nsamtest ~]# headpin -u admin -p admin product list --org=ACME_Corporation
----------------------------------------------------------------------------------------------------------------------------
                                     組織 ACME_Corporation、環境 'Library' の製品一覧、

Id  Name                                                          Label                                                         Provider Id Provider Name Sync Plan Name Last Sync GPG キー   
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------------------------------------------------
85  Red Hat Enterprise Linux Load Balancer for RHEL Server        Red_Hat_Enterprise_Linux_Load_Balancer_for_RHEL_Server        1           Red Hat                
...

[root@i18nsamtest ~]# headpin -u admin -p admin product list --org=test
Couldn't find organization 'test'
^^^^^^^^^^^^^^^^^^Unlocalized


  
Actual results:
Unlocalized strings for product module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:56 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Hedda Peters 2012-12-13 01:23:48 EST
Pretty much the same outcome for de-DE.

Currently all languages are at least 95% translated on Zanata, and the remaining untranslated strings are not the unlocalized ones mentioned above. Some of the unlocalized strings mentioned above are translated on Zanata, others are not in our translation files on Zanata yet.
Comment 3 Noriko Mizumoto 2012-12-13 02:15:08 EST
confirmed for ja-JP.
Also the following strings are not localized, and seem not included in the cfse-cli file on zanata.
e.g. Id Name Provider Id Provider Name Sync Plan Name Last Sync 

[root@i18nsamtest ~]# headpin -u admin -p admin product list --org=ACME_Corporation
------------------------------------------------------------------------------------------------
                       組織 ACME_Corporation、環境 'Library' の製品一覧、

Id  Name                                                          Label                                                         Provider Id Provider Name Sync Plan Name Last Sync GPG キー   
------------------------------------------------------------------------------------------------
90  Red Hat Enterprise Linux Resilient Storage for RHEL Server    Red_Hat_Enterprise_Linux_Resilient_Storage_for_RHEL_Server    1           Red Hat                
69  Red Hat Enterprise Linux Server                               Red_Hat_Enterprise_Linux_Server                               1           Red Hat                
83  Red Hat Enterprise Linux High Availability for RHEL Server    Red_Hat_Enterprise_Linux_High_Availability_for_RHEL_Server    1           Red Hat                
85  Red Hat Enterprise Linux Load Balancer for RHEL Server        Red_Hat_Enterprise_Linux_Load_Balancer_for_RHEL_Server        1           Red Hat                
92  Red Hat Enterprise Linux Scalable File System for RHEL Server Red_Hat_Enterprise_Linux_Scalable_File_System_for_RHEL_Server 1           Red Hat                
180 Red Hat Beta                                                  Red_Hat_Beta                                                  1           Red Hat                
71  Red Hat Enterprise Linux Workstation                          Red_Hat_Enterprise_Linux_Workstation                          1           Red Hat                
[root@i18nsamtest ~]#
Comment 4 Lijun Li 2012-12-13 06:13:23 EST
*** Bug 886772 has been marked as a duplicate of this bug. ***
Comment 5 Eunju, Kim 2012-12-13 17:43:06 EST
confirmed for ko-KR.
Comment 6 Sam Friedmann 2012-12-13 20:21:50 EST
Confirmed for fr-FR.
Comment 7 Wei Liu 2012-12-13 20:29:07 EST
confirmed for zh-CN.
Comment 8 Tom McKay 2012-12-18 09:12:24 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 10 Bryan Kearney 2013-06-07 14:20:35 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 11 Bryan Kearney 2013-06-07 14:29:03 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.