Bug 87919 - kbdconfig missing - needed by kudzu
kbdconfig missing - needed by kudzu
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kbdconfig (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
: 87924 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 13:44 EST by Tom Wood
Modified: 2007-04-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-21 11:15:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2003-04-03 13:44:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After upgrading an Abit AT7 MAX mobo (with no PS/2 ports) from RH8.0 to RH9, I
lost all keyboard and mouseability.  I'm connected for keyboard and mouse via
USB to an Aten USB KVM.  Direct connection of keyboard (bypassing KVM) doesn't help.

Running kudzu, it removed my keyboard and Aten KVM.  Upon further examination,
it seems that the usb-uhci module isn't loading!  After modprobing usb-uhci and
running kudzu, kudzu bombs with the error

sh: line 1: /usr/sbin/kbdconfig: No such file or directory

.  kdbconfig isn't a valid package under RH 9.

Should I also file a bug against modutils/kernel to deal with the usb-uhci issue?




Version-Release number of selected component (if applicable):
kbdconfig nonexistent, kudzu 0.99.99

How reproducible:
Always

Steps to Reproduce:
1.Upgrade RH 8.0 on an Abit AT7 MAX to RH9.
2.Watch your keyboard and mouse disappear not work.
3.Watch kudzu timeout during boot because the keyboard doesn't work.
4.ssh into the box.
5.Run kudzu and watch it remove your USB devices.
6.Run lsmod and see no USB modules.
7.modprobe usb-uhci.
8.Run kudzu again and watch it bomb out with the error message above.
    

Actual Results:  kudzu can't find /usr/sbin/kbdconfig

Expected Results:  kudzu should have found kbdconfig or its replacement. The
usb-uhci module should have been loadad automagically as well.

Additional info:
Comment 1 Tom Wood 2003-04-03 14:08:33 EST
*** Bug 87924 has been marked as a duplicate of this bug. ***
Comment 2 Brent Fox 2003-05-21 11:15:24 EDT
Should be fixed in kuduz-1.1.4-1.1 in Rawhide.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.