Bug 87924 - kbdconfig missing - needed by kudzu
Summary: kbdconfig missing - needed by kudzu
Keywords:
Status: CLOSED DUPLICATE of bug 87919
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbdconfig
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-03 19:06 UTC by Tom Wood
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:27 UTC


Attachments (Terms of Use)

Description Tom Wood 2003-04-03 19:06:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After upgrading an Abit AT7 MAX mobo (with no PS/2 ports) from RH8.0 to RH9, I
lost all keyboard and mouseability.  I'm connected for keyboard and mouse via
USB to an Aten USB KVM.  Direct connection of keyboard (bypassing KVM) doesn't help.

Running kudzu, it removed my keyboard and Aten KVM.  Upon further examination,
it seems that the usb-uhci module isn't loading!  After modprobing usb-uhci and
running kudzu, kudzu bombs with the error

sh: line 1: /usr/sbin/kbdconfig: No such file or directory

.  kdbconfig isn't a valid package under RH 9.

Should I also file a bug against modutils/kernel to deal with the usb-uhci issue?




Version-Release number of selected component (if applicable):
kbdconfig nonexistent, kudzu 0.99.99

How reproducible:
Always

Steps to Reproduce:
1.Upgrade RH 8.0 on an Abit AT7 MAX to RH9.
2.Watch your keyboard and mouse disappear not work.
3.Watch kudzu timeout during boot because the keyboard doesn't work.
4.ssh into the box.
5.Run kudzu and watch it remove your USB devices.
6.Run lsmod and see no USB modules.
7.modprobe usb-uhci.
8.Run kudzu again and watch it bomb out with the error message above.
    

Actual Results:  kudzu can't find /usr/sbin/kbdconfig

Expected Results:  kudzu should have found kbdconfig or its replacement. The
usb-uhci module should have been loadad automagically as well.

Additional info:

Comment 1 Tom Wood 2003-04-03 19:08:29 UTC
Stupid me - duped myself.

*** This bug has been marked as a duplicate of 87919 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.