Bug 879195 - [ALL LANG][SAM CLI] Unlocalized strings for shell module.
[ALL LANG][SAM CLI] Unlocalized strings for shell module.
Status: CLOSED NEXTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
x86_64 Linux
medium Severity medium
: rc
: 2.0
Assigned To: Adam Price
SAM QE List
: Translation, Triaged
: 886767 (view as bug list)
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-22 05:16 EST by Lijun Li
Modified: 2013-06-07 14:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 14:28:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2012-11-22 05:16:55 EST
Description of problem:
Unlocalized strings for shell module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
[root@i18nsamtest ~]# headpin -u admin -p admin shell
sam> test
*** Unknown syntax: test
^^^^^^^^^^^^^^^^^^Unlocalized
sam> user list
--------------------------------------------------------------------------------------------------------------------------
                                                      ユーザーの一覧

Id Username      Email              Disabled Default Organization Default Environment 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
--------------------------------------------------------------------------------------------------------------------------
3  en_US         en_US@localhost    False    None                 None                
...

sam> user_role list
--------------------------------------------------------------------------------------------------------------------------
                                                    ユーザーロール一覧

Id Name
^^^^^^Unlocalized            
--------------------------------------------------------------------------------------------------------------------------
1  Administrator   
...

sam> org list
--------------------------------------------------------------------------------------------------------------------------
                                                        組織の一覧

Id Name             Label                                Description     
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized             
--------------------------------------------------------------------------------------------------------------------------
14 プ               38493752-3236-42a6-b9b0-2ca79165973b ブ      

sam> environment list --org=ACME_Corporation
--------------------------------------------------------------------------------------------------------------------------
                                                        環境の一覧

Id Name    Label   Description 組織               以前の環境      
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized 
...

sam> activation_key list --org=ACME_Corporation
--------------------------------------------------------------------------------------------------------------------------
                                               アクティベーションキーの一覧

Id Name Description 使用方法     Environment Id System Template Id 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized 
--------------------------------------------------------------------------------------------------------------------------
7  test             0        30             None  
              
sam> product list --org=ACME_Corporation
--------------------------------------------------------------------------------------------------------------------------
                                    組織 ACME_Corporation、環境 'Library' の製品一覧、

Id  Name                                                          Label                                                         Provider Id Provider Name Sync Plan Name Last Sync GPG キー  
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized 

 system list --org=ACME_Corporation
--------------------------------------------------------------------------------------------------------------------------
                                         組織 [ ACME_Corporation ] のシステム一覧

Name                   Uuid                                 Ipv4 Address サービス
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
レベル        
--------------------------------------------------------------------------------------------------------------------------
i18nsamtest.redhat.com 59cc3483-15b4-456c-905c-8eccdfb6bfdd 10.66.10.14  None           



Actual results:
Unlocalized strings for shell module

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:52 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 02:35:40 EST
confirmed for ja-JP
Comment 3 Lijun Li 2012-12-13 05:36:21 EST
*** Bug 886767 has been marked as a duplicate of this bug. ***
Comment 4 Eunju, Kim 2012-12-13 17:57:08 EST
confirmed for ko-KR.
Comment 5 Sam Friedmann 2012-12-13 20:23:43 EST
Confirmed for fr-FR.
Comment 6 Tom McKay 2012-12-18 09:11:54 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 8 Bryan Kearney 2013-06-07 14:20:09 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 9 Bryan Kearney 2013-06-07 14:28:30 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.

Note You need to log in before you can comment on or make changes to this bug.