Bug 879418 - dmraid package postuninstall scriptlet causes "scriptlet failed, exit status 1"
dmraid package postuninstall scriptlet causes "scriptlet failed, exit status 1"
Status: CLOSED DUPLICATE of bug 877840
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-11-22 17:35 EST by Michal Jaegermann
Modified: 2012-11-26 10:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-11-26 10:54:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-11-22 17:35:28 EST
Description of problem:

While upgrading the following happens:

  Cleanup    : dmraid-1.0.0.rc16-17.fc18.x86_64                         227/445 
/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(dmraid-1.0.0.rc16-17.fc18.x86_64) scriptlet failed, exit status 1

The problem is that this scriplet looks like this:

postuninstall scriptlet (using /sbin/ldconfig):

# 1. Main package

and ldconfig attempts to execute something which in an intention was supposed to be a comment.

Version-Release number of selected component (if applicable):

Additional info:
This is not the first package where such trouble showed up.  Basically the issue is that an rpm format does not have an 'end-of-section' marker and a section ends when the next one is starting.  Therefore sticking a shell comments in random places does not work too well.
Comment 1 Adam Tkac 2012-11-26 10:54:37 EST

*** This bug has been marked as a duplicate of bug 877840 ***

Note You need to log in before you can comment on or make changes to this bug.