Bug 877840 - /sbin/ldconfig: relative path `1' used to build cache
/sbin/ldconfig: relative path `1' used to build cache
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
: 677744 879418 882991 893384 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-18 21:13 EST by Ralf Corsepius
Modified: 2013-05-13 03:24 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-11 19:13:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2012-11-18 21:13:09 EST
Description of problem:

During an attempt to upgrade a f17 installation to current f18, following the procedures described in https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum#Fedora_17_-.3E_Fedora_18

I am facing the following postun-scriptlet failure:
...
 Cleanup    : dmraid-1.0.0.rc16-16.fc17.i686                                                                                                                                   2065/3585 
Non-fatal POSTUN scriptlet failure in rpm package dmraid-1.0.0.rc16-16.fc17.i686
  Cleanup    : prelink-0.4.6-5.fc17.i686                                                                                                                                        2066/3585 
/sbin/ldconfig: relative path `1' used to build cache
warning: %postun(dmraid-1.0.0.rc16-16.fc17.i686) scriptlet failed, exit status 1
Comment 1 Adam Tkac 2012-11-26 10:53:23 EST
*** Bug 677744 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2012-11-26 10:54:37 EST
*** Bug 879418 has been marked as a duplicate of this bug. ***
Comment 3 Adam Tkac 2012-11-26 10:57:15 EST
There is very simple fix for this annoying issue. You can use either remove the "# 1. Main package" comment from dmraid.spec or remove the "-p" switch from the %postun scriptlet.
Comment 4 Fedora Update System 2012-11-28 04:36:04 EST
dmraid-1.0.0.rc16-18.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dmraid-1.0.0.rc16-18.fc18
Comment 5 Fedora Update System 2012-11-28 16:11:43 EST
Package dmraid-1.0.0.rc16-18.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dmraid-1.0.0.rc16-18.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19295/dmraid-1.0.0.rc16-18.fc18
then log in and leave karma (feedback).
Comment 6 Peter Rajnoha 2012-12-03 10:56:08 EST
*** Bug 882991 has been marked as a duplicate of this bug. ***
Comment 7 Peter Rajnoha 2013-01-09 05:05:14 EST
*** Bug 893384 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-01-11 19:13:55 EST
dmraid-1.0.0.rc16-18.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Pay87 2013-05-11 15:52:22 EDT
I still got the failure message while updating:

warning: %postun(dmraid-1.0.0.rc16-17.fc18.x86_64) scriptlet failed, exit status 1
Non-fatal POSTUN scriptlet failure in rpm package dmraid-1.0.0.rc16-17.fc18.x86_64
Comment 10 Peter Rajnoha 2013-05-13 03:24:41 EDT
(In reply to comment #9)
> I still got the failure message while updating:
> 
> warning: %postun(dmraid-1.0.0.rc16-17.fc18.x86_64) scriptlet failed, exit
> status 1
> Non-fatal POSTUN scriptlet failure in rpm package
> dmraid-1.0.0.rc16-17.fc18.x86_64

POSTUN scriptlets are run from old packages on update to new packages.

So if you're updating to dmraid-1.0.0.rc16-18.fc18, you still get the error message from the previous one dmraid-1.0.0.rc16-17.fc18.x86_64.

So what you see is OK. The error will be gone completely only if updating to (future) dmraid-1.0.0.rc16-19.fc18 and higher.

Note You need to log in before you can comment on or make changes to this bug.