Bug 87948 - modutils not loading usb-uhci
modutils not loading usb-uhci
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-03 17:27 EST by Tom Wood
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv of affected machine (8.52 KB, text/plain)
2003-04-03 20:18 EST, Tom Wood
no flags Details
/etc/sysconfig/hwconf from affected machine (4.56 KB, text/plain)
2003-04-04 10:27 EST, Tom Wood
no flags Details
/etc/modules.conf from affected machine (605 bytes, text/plain)
2003-04-04 10:27 EST, Tom Wood
no flags Details
Results of "modprobe -c" from affected machine (5.90 KB, text/plain)
2003-04-04 15:53 EST, Tom Wood
no flags Details

  None (edit)
Description Tom Wood 2003-04-03 17:27:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Modutils isn't loading usb-uhci.  This on an Abit AT7 MAX mobo means that I
don't get any keyboard/mouse, since this thing is PS/2-free.

It's loading usb-ehci for the USB 2.0 ports, and the hid, usbcore, and input
modules are being loaded against the 2.0 ports.

Version-Release number of selected component (if applicable):
modutils-2.4.22-8

How reproducible:
Always

Steps to Reproduce:
1.Boot RH 9 on an Abit AT7 MAX
2.Find no keyboard/mouse.
3.Sulk...
    

Actual Results:  No input devices

Expected Results:  Keyboard and mouse happy as before upgrade.

Additional info:  sshing in and modprobing usb-uhci is a workaround.
Comment 1 Bill Nottingham 2003-04-03 18:57:52 EST
lspci output?
Comment 2 Tom Wood 2003-04-03 20:18:15 EST
Created attachment 90890 [details]
lspci -vvv of affected machine
Comment 3 Bill Nottingham 2003-04-03 22:28:18 EST
Odd, can you post /etc/sysconfig/hwconf and /etc/modules.conf?
Comment 4 Tom Wood 2003-04-04 10:27:07 EST
Created attachment 90897 [details]
/etc/sysconfig/hwconf from affected machine
Comment 5 Tom Wood 2003-04-04 10:27:31 EST
Created attachment 90898 [details]
/etc/modules.conf from affected machine
Comment 6 Bill Nottingham 2003-04-04 11:23:08 EST
Does it try to load both controller modules on boot, or *only* ehci-hcd?
If it tries both, are there errors from loading usb-uhci?
Comment 7 Tom Wood 2003-04-04 14:53:03 EST
I don't see it trying to load usb-uhci during boot at all, just ehci-hcd. 
Nothing turns up in /var/log/messages or /var/log/boot.log pertaining to usb-uhci.
Comment 8 Tom Wood 2003-04-04 15:28:13 EST
Something else I've noticed is that during boot, two lines refer to loading
ehci-hcd, back to back.  This was during rc.sysinit.  There's a clue to the
problem in rc.sysinit in line 174.  This line attempts to pull out all of the
usb devices in the current modprobe configuration, which for whatever reason
doesn't match /etc/modules.conf.  I'll attach the output of "modprobe -c" where
you can see that the usb-controller and usb-controller1 definitions are
different in /etc/modules.conf, but the same in "modprobe -c".
Comment 9 Tom Wood 2003-04-04 15:28:49 EST
Something else I've noticed is that during boot, two lines refer to loading
ehci-hcd, back to back.  This was during rc.sysinit.  There's a clue to the
problem in rc.sysinit in line 174.  This line attempts to pull out all of the
usb devices in the current modprobe configuration, which for whatever reason
doesn't match /etc/modules.conf.  I'll attach the output of "modprobe -c" where
you can see that the usb-controller and usb-controller1 definitions are
different in /etc/modules.conf, but the same in "modprobe -c".
Comment 10 Tom Wood 2003-04-04 15:52:01 EST
Apologies for the duplicate.  Bugzilla falsely detected a mid-air collision that
I couldn't recover from gracefully.
Comment 11 Tom Wood 2003-04-04 15:53:09 EST
Created attachment 90911 [details]
Results of "modprobe -c" from affected machine
Comment 12 Bill Nottingham 2003-04-04 16:12:28 EST
Your modules.conf has:

alias usb-controller usb-uhci
alias usb-controller1 ehci-hcd
alias ieee1394-controller ohci1394
...
alias usb-controller ehci-hcd

The second entry for usb-controller is overriding the first when run through
modprobe -c.

Is your modules.conf exactly as it was written after install?
Comment 13 Tom Wood 2003-04-04 21:46:09 EST
Yes, the attachments reflect the current state of the machine.  That's what has
me badly confused - modprobe seems borked.
Comment 14 Bill Nottingham 2003-04-07 17:04:41 EDT
No, it's behaving correctly. You have two entries for 'usb-controller' in
modules.conf; the later one overrides the first.

So the question then is: how did two entries for usb-controller get added in
that way? Is that how modules.conf looked right after you installed?
Comment 15 Tom Wood 2003-04-07 18:23:33 EDT
You are correct that the usb-controller entry is in modules.conf twice.  I
didn't catch that. This is the state of /etc/modules.conf as a result of the
upgrade.  The date on the file is consistent with when I performed the upgrade.
 I've done no hand-editing post-upgrade.

Just as a data point, this box has eight USB ports.  Four of them are usb-uhci
and four of them are ehci-hcd, all coming from the mobo.
Comment 16 Mark Levitt 2003-04-13 18:57:30 EDT
Hi,
I'm having the same problem. 

After upgrading from RedHat 8.0 to 9, my USB mouse stopped working. 

It worked during the upgrade (in anaconda). 

modprobing uhci fixes it. 

I also have two entries in modules.conf that specify the uhci module and then a
duplicate specifying the ehci module. 

So, how do I configure modules.conf to load both the uhci and ehci modules? Both
need to be loaded to support USB 1.1 and 2.0 devices.

Comment 17 Need Real Name 2003-04-13 19:14:59 EDT
I have quite a similar problem with the exact same modules.conf.  I also did an upgrade from 
rh8 to rh9 and all my usb devices ceased functioning.  My modules.conf looks like this: 
 
alias parport_lowlevel parport_pc 
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || : 
alias usb-controller usb-uhci 
alias eth0 3c59x 
alias usb-controller1 ehci-hcd 
alias ieee1394-controller ohci1394 
alias sound-slot-0 emu10k1 
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || : 
alias eth1 e100 
alias usb-controller ehci-hcd 
alias char-major-195 nvidia 
 
my fix was to make a new initrd like so: 
 
mkinitrd --preload=uhci initrd-2.4.20-9.img 2.4.20-9 
 
Is that the right way to go, or should we do something clever in modules.conf to fix it? 
Comment 18 Bill Nottingham 2003-04-14 13:33:50 EDT
Just change it so that they're all distinct, i.e.:

usb-controller
usb-controller1
usb-controller2

Also, you only need one for each module.
Comment 19 Need Real Name 2003-04-14 13:37:31 EDT
So, is this an anaconda bug which only happens on upgrade?  Or it's just
specific to motherboards having usb 1 and usb 2 controllers?  

BTW, I think bug 85933 may be a dupe of this bug.
Comment 20 Bill Nottingham 2003-04-14 13:47:35 EDT
Yes, it's an anaconda upgrade bug.
Comment 21 Brent Fox 2003-05-25 10:57:54 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.