Bug 879595 - regression: window size managment broken
Summary: regression: window size managment broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Jan Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 892089
TreeView+ depends on / blocked
 
Reported: 2012-11-23 12:11 UTC by Enrico Scholz
Modified: 2013-01-12 00:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 892089 (view as bug list)
Environment:
Last Closed: 2013-01-05 06:57:49 UTC


Attachments (Terms of Use)
Scrollbar bug screenshot. (20.54 KB, image/png)
2012-12-25 07:49 UTC, Jan Kratochvil
no flags Details


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 813997 None None None Never

Description Enrico Scholz 2012-11-23 12:11:28 UTC
Description of problem:

With firefox 17 I am unable to resize the 'firefox' window. E.g. when pressing the 'maximize' button, nothing happens.  Dragging the border shrinks the window to thumbnail size and there is no way to restore the original size.  This makes working with firefox completely impossible.

Things worked fine with 16.0.2 and are working again after downgrading to firefox-16.0.2 + xulrunner-16.0.2.


Version-Release number of selected component (if applicable):

firefox-17.0-1.fc17.x86_64
xulrunner-17.0-3.fc17.x86_64

sawfish-1.8.92-1.fc17.x86_64


How reproducible:

100%

Comment 1 Martin Stransky 2012-11-23 13:04:26 UTC
First of all, which desktop environment do you run? And can you try another one? Like gnome fallback mode or so?

Comment 2 Enrico Scholz 2012-11-23 13:06:59 UTC
sawfish with xfce panel

Comment 3 Martin Stransky 2012-11-26 11:51:22 UTC
Please try different WM (gnome, kde).

Comment 4 Paul Szabo 2012-11-26 19:27:56 UTC
Seems the bug is within Mozilla:
https://bugzilla.mozilla.org/show_bug.cgi?id=813997

Comment 5 Jan Kratochvil 2012-12-05 14:19:31 UTC
With 17.0 started (and 17.0.1 has not fixed it) a regression where the window scrollbar stays at the top and not moving.  One can scroll by PageUp/PageDown.
Using F16 XFCE.

Comment 6 Jan "Yenya" Kasprzak 2012-12-06 17:46:11 UTC
Me too, Fedora 17, sawfish + xfce.

Firefox 17 starts bigger than the screen size, and can be only resized to 0x800 or something like that. Trying to maximize the window to the screen size does not help.

Comment 7 Jan "Yenya" Kasprzak 2012-12-06 17:58:26 UTC
According to

http://listengine.tuxfamily.org/lists.tuxfamily.org/sawfish/2012/12/msg00001.html

this is fixed in Sawfish 1.9.90. I am not sure whether this is a sawfish bug or Firefox bug: FF specifies the maximum window size in WM hints larger than the maximum window size in X11 (32767 pixels), and sawfish is confused by that. So maybe upgrading sawfish in Fedora would also solve this.

Comment 8 Martin Stransky 2012-12-07 09:18:40 UTC
We're going to release fixed xulrunner package for that.

Comment 9 Fedora Update System 2012-12-14 13:15:06 UTC
xulrunner-17.0.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-3.fc18

Comment 10 Fedora Update System 2012-12-14 13:15:40 UTC
xulrunner-17.0.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-2.fc16

Comment 11 Fedora Update System 2012-12-14 13:16:05 UTC
xulrunner-17.0.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-17.0.1-3.fc17

Comment 12 Fedora Update System 2012-12-14 23:19:12 UTC
Package xulrunner-17.0.1-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xulrunner-17.0.1-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20372/xulrunner-17.0.1-3.fc18
then log in and leave karma (feedback).

Comment 13 Jan Kratochvil 2012-12-25 07:49:58 UTC
Created attachment 668767 [details]
Scrollbar bug screenshot.

The Comment 5 of the scrollbar is not fixed by xulrunner-17.0.1-2.fc16.x86_64.
Although maybe it is a different Bug?
You can see I am at the top of the page but the scrollbar is at the bottom.
Reproducible about once a day.  The scrollbar updates its position either after ~5 seconds or after clicking into a different window and back.  One can scroll by mouse dragging the scrollbar, by the mouse scrollerbutton or by PgUp/PgDn and the scrollbar remains not updated.
It is a Firefox 17 regression.

Comment 14 Trevor Cordes 2012-12-26 18:34:12 UTC
I have this bug too.  I use xfce + sawfish also, so if the whole world isn't seeing this bug it's probably specific to sawfish.

firefox-17.0.1-1.fc16.i686 shows this bug for me.  Downgrade to firefox-16.0.2-1.fc16.i686 fixes the bug.

I don't see any F16 updates yet in the main repos so I am using 16.0.2.1 for now.

Comment 15 Fedora Update System 2013-01-05 06:57:51 UTC
xulrunner-17.0.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2013-01-12 00:21:50 UTC
xulrunner-17.0.1-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.