Bug 879612 - OSError: [Errno 2] No such file or directory: '/mnt/install/isodir/dvd.iso'
OSError: [Errno 2] No such file or directory: '/mnt/install/isodir/dvd.iso'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:493931f71705f1c7522add6cb3e...
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-23 07:44 EST by Kamil Páral
Modified: 2012-12-06 07:00 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-18.35-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 02:29:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (172.33 KB, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: product (6 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: type (9 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: storage.log (45.87 KB, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: version (7 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: environ (780 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: executable (14 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: anaconda.log (7.61 KB, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: syslog (61.15 KB, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: packaging.log (4.43 KB, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: cmdline_file (110 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: release (24 bytes, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details
File: program.log (25.20 KB, text/plain)
2012-11-23 07:45 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-11-23 07:44:59 EST
Description of problem:
Read bug 876897 comment 14.

Version-Release number of selected component:
anaconda-18.29.2

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.6-3.fc18.i686

description:
:The following was filed automatically by anaconda:
:anaconda 18.29.2 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pyanaconda/image.py", line 41, in findFirstIsoImage
:    flush = os.stat(path)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 520, in _setUpMedia
:    image = findFirstIsoImage(path)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 587, in _configureBaseRepo
:    self._setUpMedia(isodevice)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 411, in updateBaseRepo
:    self._configureBaseRepo(self.storage, checkmount=checkmount)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 531, in getRepoMetadata
:    self.payload.updateBaseRepo(fallback=False, checkmount=False)
:  File "/usr/lib/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:OSError: [Errno 2] No such file or directory: '/mnt/install/isodir/dvd.iso'
Comment 1 Kamil Páral 2012-11-23 07:45:03 EST
Created attachment 650411 [details]
File: anaconda-tb
Comment 2 Kamil Páral 2012-11-23 07:45:05 EST
Created attachment 650412 [details]
File: product
Comment 3 Kamil Páral 2012-11-23 07:45:07 EST
Created attachment 650413 [details]
File: type
Comment 4 Kamil Páral 2012-11-23 07:45:09 EST
Created attachment 650414 [details]
File: ifcfg.log
Comment 5 Kamil Páral 2012-11-23 07:45:11 EST
Created attachment 650415 [details]
File: storage.log
Comment 6 Kamil Páral 2012-11-23 07:45:13 EST
Created attachment 650416 [details]
File: version
Comment 7 Kamil Páral 2012-11-23 07:45:15 EST
Created attachment 650417 [details]
File: environ
Comment 8 Kamil Páral 2012-11-23 07:45:17 EST
Created attachment 650418 [details]
File: executable
Comment 9 Kamil Páral 2012-11-23 07:45:19 EST
Created attachment 650419 [details]
File: anaconda.log
Comment 10 Kamil Páral 2012-11-23 07:45:21 EST
Created attachment 650420 [details]
File: syslog
Comment 11 Kamil Páral 2012-11-23 07:45:24 EST
Created attachment 650421 [details]
File: hashmarkername
Comment 12 Kamil Páral 2012-11-23 07:45:26 EST
Created attachment 650422 [details]
File: packaging.log
Comment 13 Kamil Páral 2012-11-23 07:45:28 EST
Created attachment 650423 [details]
File: cmdline_file
Comment 14 Kamil Páral 2012-11-23 07:45:30 EST
Created attachment 650424 [details]
File: release
Comment 15 Kamil Páral 2012-11-23 07:45:32 EST
Created attachment 650425 [details]
File: program.log
Comment 16 Kamil Páral 2012-11-23 07:51:04 EST
 The installer must be able to use all supported local and remote package source options 
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 17 Adam Williamson 2012-11-29 14:29:26 EST
Discussed at 2012-11-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-29/f18final-blocker-review-1.1.2012-11-29-17.01.log.txt . Accepted as a blocker per criterion cited in comment #16.
Comment 18 Michael Schwendt 2012-11-30 08:43:18 EST
Revisited the manual partition problem described on test list, entered "SOFTWARE -> Installation Source", click the tiny empty area left of the "Verify" button, pointed the file dialog at the DVD ISO image on harddisk, clicked the "Verify" button, afterwards "Done" to return to the main "INSTALLATION SUMMARY" screen. Did not do anything else, the traceback appeared automatically.

Package: anaconda-18.29.2
Architecture: x86_64
OS Release: Fedora release 18-Beta
Comment 19 Chris Lumens 2012-12-04 12:07:39 EST
Minimal reproducer steps:

(1) Boot with inst.repo=hd:whatever.
(2) Go into source spoke and change to closest mirror (probably, changing to any other source would cause the same problem but I have not tested).
(3) Go back to the hub and wait.
(4) Go back to the source spoke and change back to the HDISO source.
(5) Go back to the hub and wait for the traceback.

I've not yet tested a later build than the one in the beta, but I'll do that after lunch.
Comment 20 Chris Lumens 2012-12-04 13:29:18 EST
Same result with anaconda out of git.
Comment 21 Fedora Update System 2012-12-04 19:56:55 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
Comment 22 Fedora Update System 2012-12-05 18:13:06 EST
Package pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.22-1.fc18 anaconda-18.35-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19380/pykickstart-1.99.22-1.fc18,anaconda-18.35-1.fc18
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2012-12-06 02:29:05 EST
pykickstart-1.99.22-1.fc18, anaconda-18.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Kamil Páral 2012-12-06 07:00:59 EST
This seems to be fixed in anaconda 18.36.

Note You need to log in before you can comment on or make changes to this bug.