Bug 876897 - inst.repo=hd: installation shows error on main hub in package selection, but seems to work
inst.repo=hd: installation shows error on main hub in package selection, but ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedNTH
: Reopened
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-15 04:03 EST by Kamil Páral
Modified: 2013-01-09 21:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-03 04:23:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (5.39 KB, text/plain)
2012-11-15 04:04 EST, Kamil Páral
no flags Details
packaging.log (2.84 KB, text/plain)
2012-11-15 04:04 EST, Kamil Páral
no flags Details
program.log (26.39 KB, text/plain)
2012-11-15 04:04 EST, Kamil Páral
no flags Details
storage.log (49.74 KB, text/plain)
2012-11-15 04:04 EST, Kamil Páral
no flags Details
syslog (59.41 KB, text/plain)
2012-11-15 04:04 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-11-15 04:03:44 EST
Description of problem:
I followed this test case:
https://fedoraproject.org/wiki/QA:Testcase_install_repository_Hard_drive_variation

When pxebooted, Anaconda correctly loads stage2 from the DVD on the specified disk partition, but doesn't use the internal package repo, instead it defaults to Closest Mirror, and the internal repo can't even be selected in the GUI.

Version-Release number of selected component (if applicable):
F18 Beta TC8
anaconda 18.28

How reproducible:
always

Steps to Reproduce:
1. use the linked test case to boot with inst.repo=hd:device:/dir or inst.repo=hd:device:/dir/dvd.iso
2. see Installation Source dialog
  
Actual results:
Closest Mirror is selected

Expected results:
internal DVD repo is selected

Additional info:
Comment 1 Kamil Páral 2012-11-15 04:04:08 EST
Created attachment 645507 [details]
anaconda.log
Comment 2 Kamil Páral 2012-11-15 04:04:12 EST
Created attachment 645508 [details]
packaging.log
Comment 3 Kamil Páral 2012-11-15 04:04:23 EST
Created attachment 645509 [details]
program.log
Comment 4 Kamil Páral 2012-11-15 04:04:27 EST
Created attachment 645510 [details]
storage.log
Comment 5 Kamil Páral 2012-11-15 04:04:30 EST
Created attachment 645511 [details]
syslog
Comment 6 Kamil Páral 2012-11-15 04:05:30 EST
Same as in bug 876223, I think this could be a Final blocker:
" The installer must be able to use all supported local and remote package source options "
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 7 Adam Williamson 2012-11-19 13:01:55 EST
proposing as NTH for Beta, as jlk's interested in getting the fix in. Anyone have a vote?
Comment 8 Tim Flink 2012-11-19 13:09:58 EST
+1 NTH for a tested fix - this would be a final blocker and can't be fixed with an update after beta is released.
Comment 9 Kevin Fenzi 2012-11-19 15:10:16 EST
+1 NTH here as well.
Comment 10 Adam Williamson 2012-11-19 15:36:35 EST
+3 -> acceptednth.
Comment 11 Fedora Update System 2012-11-20 17:03:17 EST
anaconda-18.29.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
Comment 12 Fedora Update System 2012-11-21 15:51:47 EST
Package anaconda-18.29.2-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29.2-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18468/anaconda-18.29.2-1.fc18
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-11-23 02:28:27 EST
anaconda-18.29.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Kamil Páral 2012-11-23 07:49:33 EST
I was able to hand-select the dvd.iso on a local partition, but that triggered bug 879610.

When I booted with inst.repo=hd:vda1:/ or inst.repo=hd:vda1:/dvd.iso, the main screen says "Error setting up install source". I tried to switch to closest mirror and then back to the device, but the device itself can't be selected. When I hand-picked the dvd.iso file, it caused bug 879612.
Comment 15 Adam Williamson 2012-11-30 02:18:23 EST
Kamil, does it show an error triangle when it says 'Error setting up install source'?

Note https://bugzilla.redhat.com/show_bug.cgi?id=879142 - when testing this in a non-PXE config, I found that it shows that 'error' message, but the warning triangle does not appear, and if you just proceed with the install, it actually works fine.
Comment 16 Kamil Páral 2012-11-30 04:41:19 EST
Adam, you're right! It says "error setting up install source", but no warning icon is present, and you can begin the installation. Shortly afterwards I end up with bug 879610, but that's another story.

I think we should reopen this bug. It no longer uses Closest Mirror, that's fine, but it displays an error when it shouldn't, so still not fully fixed.
Comment 17 Tim Flink 2012-11-30 12:59:34 EST
+1 final blocker due to violation of the following F18 final release criterion [1]:

The installer must be able to use all supported local and remote package source options.

[1] http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 18 Adam Williamson 2012-11-30 23:03:48 EST
I already filed a bug for the error message, and even linked to it in my comment. Since it's clearly a different bug, it seems more sensible to track it separately. I recommend setting this back to CLOSED, if you have no objections. Plus, this issue is not PXE-specific.
Comment 19 Kamil Páral 2012-12-03 04:23:14 EST
Ah, my bad. Closing, the issue is tracked in bug 879142.

Note You need to log in before you can comment on or make changes to this bug.