This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 879716 - systemctl error messages are cryptic
systemctl error messages are cryptic
Status: CLOSED DUPLICATE of bug 880353
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-23 16:37 EST by Dimitrios Apostolou
Modified: 2013-01-14 13:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 13:01:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitrios Apostolou 2012-11-23 16:37:20 EST
I'm new to systemd, so I tried overriding a unit file by copying it to /etc/systemd/system/multi-user.target.wants/ directory and editing it there.

That was a mistake, the proper path to copy unit files is /etc/systemd/system/.

However it took me a decent amount of time to find out, since everything I tried was failing with the following message. Google gave me the answer, but as an admin I like to search things on my own. Strace'ing systemctl didn't help (it sends messages via socket) and I still don't know what was the dreaded method call that failed...

# systemctl reenable MYSERVICE   # Or almost every command on MYSERVICE
Failed to issue method call: Invalid argument
Comment 1 Lennart Poettering 2013-01-14 13:01:40 EST
The failing reenable is actually discussed here.

https://bugzilla.redhat.com/show_bug.cgi?id=880353

Merging.

*** This bug has been marked as a duplicate of bug 880353 ***

Note You need to log in before you can comment on or make changes to this bug.