Bug 880353 - RFE: systemctl enable/disable/is-enabled should invoke unit_name_mangle() on all passed unit file names
RFE: systemctl enable/disable/is-enabled should invoke unit_name_mangle() on ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
All Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 879716 893110 911130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-26 14:23 EST by Orion Poplawski
Modified: 2013-05-15 22:59 EDT (History)
11 users (show)

See Also:
Fixed In Version: systemd-201-2.fc18.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 22:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-11-26 14:23:45 EST
Description of problem:

[root@vmf18 ~]# /bin/systemctl is-active sshd
active
[root@vmf18 ~]# /bin/systemctl is-enabled sshd
Failed to issue method call: Invalid argument
[root@vmf18 ~]# /bin/systemctl is-enabled sshd.service
enabled

Version-Release number of selected component (if applicable):
systemd-195-8.fc18.x86_64
Comment 1 Michal Schmidt 2013-01-08 10:45:45 EST
*** Bug 893110 has been marked as a duplicate of this bug. ***
Comment 2 Lennart Poettering 2013-01-14 13:01:40 EST
*** Bug 879716 has been marked as a duplicate of this bug. ***
Comment 3 Lennart Poettering 2013-03-07 10:23:14 EST
Fixed in git.
Comment 4 Lennart Poettering 2013-03-07 10:50:26 EST
*** Bug 911130 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-04-10 16:14:21 EDT
systemd-201-2.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-201-2.fc18.1
Comment 6 Fedora Update System 2013-04-11 19:27:20 EDT
Package systemd-201-2.fc18.2:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-201-2.fc18.2'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5452/systemd-201-2.fc18.2
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-04-15 20:01:57 EDT
Package systemd-201-2.fc18.4:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-201-2.fc18.4'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5452/systemd-201-2.fc18.4
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-04-17 22:39:39 EDT
Package systemd-201-2.fc18.5:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-201-2.fc18.5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5452/systemd-201-2.fc18.5
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-05-07 09:41:34 EDT
systemd-201-2.fc18.6 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-5452/systemd-201-2.fc18.6
Comment 10 Fedora Update System 2013-05-09 06:03:31 EDT
Package systemd-201-2.fc18.6:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-201-2.fc18.6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5452/systemd-201-2.fc18.6
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-05-15 22:59:08 EDT
systemd-201-2.fc18.6 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.