Bug 879731 - RFE: please make python3 pytz package for f18
RFE: please make python3 pytz package for f18
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pytz (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 837156
  Show dependency treegraph
 
Reported: 2012-11-23 18:48 EST by Paulo Andrade
Modified: 2012-11-26 23:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 23:49:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-11-23 18:48:08 EST
This should be a merge of master branch in f18 branch
of pytz and then submit; but this updates the pytz
version.

This request due to
https://bugzilla.redhat.com/show_bug.cgi?id=837156#c44
Another option I have is to build python3-matplotlib
with it's bundled pytz copy.

I think just adapting the patch from
https://bugzilla.redhat.com/show_bug.cgi?id=851226
should do it, and not need to update pytz version
in f18.
Comment 1 Paulo Andrade 2012-11-24 10:22:59 EST
I was toying a bit with adding python3 support on f18
package but it does not work (also by mistake typed
"fedpkg build" instead of "fedpkg local" when doing
a last test in rawhide instead of fedpkg mockbuild
for f18...)

So, it appears the only clean way to add python3
support would be to upgrade to the rawhide version;
I tried start patching, but would require a significant
amount of patches.
Comment 2 Fedora Update System 2012-11-26 11:54:57 EST
pytz-2012d-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pytz-2012d-2.fc18
Comment 3 Fedora Update System 2012-11-26 23:49:23 EST
pytz-2012d-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.