Bug 879935 - [rhevm-upgrade] rhevm-upgrade should remove newly created pgpass in case of upgrade fails
[rhevm-upgrade] rhevm-upgrade should remove newly created pgpass in case of u...
Status: CLOSED DUPLICATE of bug 879920
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.2
Assigned To: Alex Lourie
Pavel Stehlik
integration
:
: 879934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-25 10:48 EST by Haim
Modified: 2014-01-12 19:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 12:49:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhevm-upgrade logs (42.34 KB, text/x-log)
2012-11-25 10:54 EST, Haim
no flags Details

  None (edit)
Description Haim 2012-11-25 10:48:29 EST
Description of problem:

after failed upgrade, and manual rollback, rhevm uses wrong .pgpass file located under /etc/ovirt-engine/.pgpass and not under ~/.root/.pgpass which fails authentication to data-base on next upgrade.


Would you like to proceed? (yes|no): 
2012-11-25 16:46:57::DEBUG::common_utils::868::root:: user answered: yes
2012-11-25 16:46:58::DEBUG::common_utils::361::root:: running sql query 'SELECT compatibility_version FROM storage_pool;' on db server: 'localhost'.
2012-11-25 16:46:58::DEBUG::common_utils::302::root:: Executing command --> '/usr/bin/psql -h localhost -p 5432 -U postgres -d rhevm -c SELECT compatibility_version FROM storage_pool;'
2012-11-25 16:46:58::DEBUG::common_utils::340::root:: output = 
2012-11-25 16:46:58::DEBUG::common_utils::341::root:: stderr = psql: FATAL:  password authentication failed for user "postgres"

2012-11-25 16:46:58::DEBUG::common_utils::342::root:: retcode = 2
2012-11-25 16:46:58::ERROR::rhevm-upgrade::1323::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-upgrade", line 1316, in <module>
    main(options)
  File "/usr/bin/rhevm-upgrade", line 1139, in main
    if unsupportedVersionsPresent(dbName=currentDbName):
  File "/usr/bin/rhevm-upgrade", line 756, in unsupportedVersionsPresent
    MSG_ERROR_CONNECT_DB,
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 370, in execRemoteSqlCommand
    return execCmd(cmdList=cmd, failOnError=failOnError, msg=errMsg, envDict=getPgPassEnv())
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 345, in execCmd
    raise Exception(msg)
Exception: Error: Failed to connect to database
Comment 1 Haim 2012-11-25 10:54:17 EST
Created attachment 651560 [details]
rhevm-upgrade logs
Comment 2 Haim 2012-11-25 13:19:47 EST
*** Bug 879934 has been marked as a duplicate of this bug. ***
Comment 3 Moran Goldboim 2012-11-26 05:24:53 EST
flow need to be added to rollback KB
Comment 4 Moran Goldboim 2012-12-11 12:49:04 EST
added to roll-back kb

*** This bug has been marked as a duplicate of bug 879920 ***

Note You need to log in before you can comment on or make changes to this bug.