Bug 879947 - Fritzing crashes right after startup
Fritzing crashes right after startup
Status: CLOSED DUPLICATE of bug 852568
Product: Fedora
Classification: Fedora
Component: fritzing (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ed Marshall
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-25 12:03 EST by Mebus
Modified: 2013-01-07 19:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 19:36:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of Fritzing (2.79 MB, text/plain)
2012-11-25 12:03 EST, Mebus
no flags Details

  None (edit)
Description Mebus 2012-11-25 12:03:39 EST
Created attachment 651581 [details]
strace of Fritzing

Description of problem:

Start Fritzing on Fedora 17 64bit (fritzing-0.7.5b-1.fc17.x86_64
). And click view functions to see it crash.

I attached an strace of Fritzing --debug.

This is Fritzing --debug:


"load something" 
"checking for backups" 
"load previous 0" 
"check files to load 0" 
"load last open" 
"create empty sketch" 
"init sketch widgets" 
"before creating dock" 
"before creating bins" 
"after html view" 
"init bin manager" 
"open core bin" 
"after palette model" 
"open progress /usr/share/fritzing/bins/core.fzb" 
"loading bin 'Core Parts'" 
"done loading bin 'Core Parts'" 
"close progress /usr/share/fritzing/bins/core.fzb" 
"after core bin" 
"after bin manager" 
"after creating bins" 
"create menus" 
"create toolbars" 
"after creating status bar" 
"create view switcher" 
"sticky load success 1" 
"finish up sketch loading" 
zsh: segmentation fault (core dumped)  strace -o fritzing_strace.txt Fritzing --debug
strace -o fritzing_strace.txt Fritzing --debug  4,79s user 1,56s system 41% cpu 15,165 total
Comment 1 Ed Marshall 2013-01-07 19:36:13 EST

*** This bug has been marked as a duplicate of bug 852568 ***

Note You need to log in before you can comment on or make changes to this bug.