Bug 852568 - [abrt] fritzing-0.7.5b-1.fc17: Process /usr/bin/Fritzing was killed by signal 11 (SIGSEGV)
[abrt] fritzing-0.7.5b-1.fc17: Process /usr/bin/Fritzing was killed by signal...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fritzing (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ed Marshall
Fedora Extras Quality Assurance
abrt_hash:3a3e986908a3d4c310ab0e7d5eb...
:
: 879727 879759 879947 890871 901744 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 20:38 EDT by Eduardo Villagrán Morales
Modified: 2013-01-22 21:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 22:16:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (15.21 KB, text/plain)
2012-08-28 20:38 EDT, Eduardo Villagrán Morales
no flags Details
File: maps (39.04 KB, text/plain)
2012-08-28 20:39 EDT, Eduardo Villagrán Morales
no flags Details
File: backtrace (18.05 KB, text/plain)
2012-08-28 20:39 EDT, Eduardo Villagrán Morales
no flags Details

  None (edit)
Description Eduardo Villagrán Morales 2012-08-28 20:38:54 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 3
cmdline:        Fritzing
executable:     /usr/bin/Fritzing
kernel:         3.5.1-1.fc17.i686
pid:            11214
remote_result:  NOTFOUND
time:           sáb 18 ago 2012 12:32:12 CLT
uid:            1000

backtrace:      Text file, 18487 bytes
dso_list:       Text file, 15580 bytes
maps:           Text file, 39976 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/eduardo/3

core_backtrace:
:- 0x0 - - -
:37b443869555e179fa92e7616c2dd0e5202cb46f 0x860fd5 QUndoStack::push(QUndoCommand*) libQtGui.so.4 -
:eeb6dc7cdbc74af7f6fa1a10b910c6447d7adc8e 0xfbf0b - [exe] -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x197cde QMetaObject::activate(QObject*, libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x1e9566 QTimer::timeout() libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x19eee6 QTimer::timerEvent(QTimerEvent*) libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x195aec QObject::event(QEvent*) libQtCore.so.4 -
:37b443869555e179fa92e7616c2dd0e5202cb46f 0x155ecc QApplicationPrivate::notify_helper(QObject*, libQtGui.so.4 -
:37b443869555e179fa92e7616c2dd0e5202cb46f 0x15a98f QApplication::notify(QObject*, libQtGui.so.4 -
:eeb6dc7cdbc74af7f6fa1a10b910c6447d7adc8e 0x96689 - [exe] -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x17f5ee QCoreApplication::notifyInternal(QObject*, libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x1b4610 - libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x1b1619 - libQtCore.so.4 -
:d4648a6d0b3baa7a362f083fd15285686b1503f3 0x46fbb g_main_context_dispatch libglib-2.0.so.0 -
:d4648a6d0b3baa7a362f083fd15285686b1503f3 0x47360 - libglib-2.0.so.0 -
:d4648a6d0b3baa7a362f083fd15285686b1503f3 0x47442 g_main_context_iteration libglib-2.0.so.0 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x1b1ca2 QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) libQtCore.so.4 -
:37b443869555e179fa92e7616c2dd0e5202cb46f 0x2083eb - libQtGui.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x17e08d QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x17e389 QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) libQtCore.so.4 -
:b1fc8ec69a34458bab61c14c7735324473a5cffc 0x1838cb QCoreApplication::exec() libQtCore.so.4 -
:37b443869555e179fa92e7616c2dd0e5202cb46f 0x153d25 QApplication::exec() libQtGui.so.4 -
:eeb6dc7cdbc74af7f6fa1a10b910c6447d7adc8e 0x42b14 - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=caleuche
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=22ebc636491d3b7de29ec58c00000013-1345302113.509089-1200389693
:QTDIR=/usr/lib/qt-3.3
:QTINC=/usr/lib/qt-3.3/include
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1180
:LANG=es_ES.utf8
:GDM_LANG=es_ES.utf8
:'PS1=[\\u@\\h \\W $(parse_git_branch)]$ '
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:SHLVL=1
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-tTDIoMFkxw,guid=740ea0cc93e7657a1d29493d000000ef
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1184,unix/unix:/tmp/.ICE-unix/1184
:LC_TIME=es_CL.utf8
:LC_NUMERIC=es_CL.utf8
:LC_MONETARY=es_CL.utf8
:LC_MEASUREMENT=es_CL.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 16385                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       16385                16385                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/eduardo/.xsession-errors
:pos:	635259
:flags:	02002
:2:/home/eduardo/.xsession-errors
:pos:	635259
:flags:	02002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[399108]
:pos:	0
:flags:	02004000
:5:pipe:[399108]
:pos:	0
:flags:	02004001
:6:socket:[399109]
:pos:	0
:flags:	02004002
:7:socket:[399110]
:pos:	0
:flags:	02004002
:8:socket:[399113]
:pos:	0
:flags:	02004002
:9:socket:[399114]
:pos:	0
:flags:	02000002
:10:/dev/urandom
:pos:	0
:flags:	02100000
:11:socket:[399214]
:pos:	0
:flags:	02004002
:12:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:13:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:14:socket:[438969]
:pos:	0
:flags:	02004002

var_log_messages:
:Aug 18 12:32:12 localhost kernel: [ 5658.259694] Fritzing[11214]: segfault at c ip 0000000c sp bf8a644c error 4 in Fritzing[803b000+6fc000]
:Aug 18 12:32:17 localhost abrt[11482]: Saved core dump of pid 11214 (/usr/bin/Fritzing) to /var/spool/abrt/ccpp-2012-08-18-12:32:12-11214 (143757312 bytes)
Comment 1 Eduardo Villagrán Morales 2012-08-28 20:38:58 EDT
Created attachment 607707 [details]
File: dso_list
Comment 2 Eduardo Villagrán Morales 2012-08-28 20:39:00 EDT
Created attachment 607708 [details]
File: maps
Comment 3 Eduardo Villagrán Morales 2012-08-28 20:39:02 EDT
Created attachment 607709 [details]
File: backtrace
Comment 4 Ed Marshall 2013-01-07 19:36:04 EST
*** Bug 890871 has been marked as a duplicate of this bug. ***
Comment 5 Ed Marshall 2013-01-07 19:36:13 EST
*** Bug 879947 has been marked as a duplicate of this bug. ***
Comment 6 Ed Marshall 2013-01-07 19:36:50 EST
*** Bug 879759 has been marked as a duplicate of this bug. ***
Comment 7 Ed Marshall 2013-01-07 19:36:54 EST
*** Bug 879727 has been marked as a duplicate of this bug. ***
Comment 8 Ed Marshall 2013-01-07 19:38:01 EST
This appears to be fixed in a newer release of Fritzing; working on that now in Bug 892556.
Comment 9 Fedora Update System 2013-01-08 01:05:15 EST
fritzing-0.7.11b-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fritzing-0.7.11b-1.fc17
Comment 10 Fedora Update System 2013-01-08 01:05:35 EST
fritzing-0.7.11b-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fritzing-0.7.11b-1.fc18
Comment 11 Fedora Update System 2013-01-08 01:21:02 EST
fritzing-0.7.11b-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fritzing-0.7.11b-1.fc16
Comment 12 Wolfgang Denk 2013-01-08 02:19:21 EST
Tested fritzing-0.7.11b-1.fc17.x86_64 ; result: still crashes
(but I cannot tell for sure if this is the same bug, or a new one).

This still crashes with Segmentation fault for the most simple operations. For example, try:
- start Fritzing
- In "Parts", select group "Connection"
- Chose the first entry ("generic female header - 2 pins")
- Place this anywhere on the breadboard
- Click on "Rotate"
- Move it on the breadboard to another location
  ==> Kaboom!

Actually it seems that moving any component after it has been
rotated will crash the program - but eventually it will take
2 or 3 moves.
Comment 13 Fedora Update System 2013-01-08 15:17:21 EST
Package fritzing-0.7.11b-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fritzing-0.7.11b-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0422/fritzing-0.7.11b-1.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-01-08 23:03:45 EST
fritzing-0.7.11b-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fritzing-0.7.11b-2.fc17
Comment 15 Fedora Update System 2013-01-08 23:04:16 EST
fritzing-0.7.11b-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/fritzing-0.7.11b-2.fc16
Comment 16 Fedora Update System 2013-01-08 23:04:34 EST
fritzing-0.7.11b-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fritzing-0.7.11b-2.fc18
Comment 17 Ed Marshall 2013-01-18 18:52:28 EST
*** Bug 901744 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2013-01-19 22:16:25 EST
fritzing-0.7.11b-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-01-22 21:06:59 EST
fritzing-0.7.11b-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-01-22 21:08:56 EST
fritzing-0.7.11b-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.