Bug 879999 - eclipse-pdebuild fails with FileNotFoundException for genericTargets.xml
eclipse-pdebuild fails with FileNotFoundException for genericTargets.xml
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
: Reopened
: 962239 (view as bug list)
Depends On: 974108 974112 1000740
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-25 18:20 EST by Gerard Ryan
Modified: 2014-01-12 19:27 EST (History)
9 users (show)

See Also:
Fixed In Version: icu4j-50.1.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 19:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2012-11-25 18:20:07 EST
Description of problem:
When building plugins with the eclipse-pdebuild script in rawhide, a FileNotFoundException is thrown.
See http://kojipkgs.fedoraproject.org//work/tasks/6101/4726101/build.log for a more up-to-date output. From what I can see, it seems to be that the genericTargets.xml file is being looked for in a subdirectory of /usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.8.1.v20121113-1808/scripts/ when in fact it's in that folder itself, not in whatever directory is being named as ${eclipse.pdebuild.scripts}

Version-Release number of selected component (if applicable):
eclipse-pde-4.2.1-19.fc19
Comment 1 Krzysztof Daniel 2012-11-26 06:09:18 EST
I've restored javax.xml. This change cannot be done now - too many places to check. The build should work now.
Comment 2 Gerard Ryan 2012-11-26 12:13:30 EST
(In reply to comment #1)
> I've restored javax.xml. This change cannot be done now - too many places to
> check. The build should work now.

Thanks a lot, it builds fine now:
https://koji.fedoraproject.org/koji/buildinfo?buildID=367581
Comment 3 Gerard Ryan 2013-05-11 12:10:29 EDT
I'm seeing this again in Rawhide/f19, with eclipse >= 1:4.3.0-0.41

It's preventing me from using pdebuild to build packages.

See:
Rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=5366642
F19: http://koji.fedoraproject.org/koji/taskinfo?taskID=5366602
Comment 4 Krzysztof Daniel 2013-05-13 09:05:52 EDT
*** Bug 962239 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-05-13 09:33:55 EDT
sat4j-2.3.4-1.fc19,jsch-0.1.50-1.fc19,eclipse-4.3.0-0.45.git4bccf2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sat4j-2.3.4-1.fc19,jsch-0.1.50-1.fc19,eclipse-4.3.0-0.45.git4bccf2.fc19
Comment 6 Fedora Update System 2013-05-13 23:46:22 EDT
Package sat4j-2.3.4-1.fc19, jsch-0.1.50-1.fc19, eclipse-4.3.0-0.45.git4bccf2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sat4j-2.3.4-1.fc19 jsch-0.1.50-1.fc19 eclipse-4.3.0-0.45.git4bccf2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8126/sat4j-2.3.4-1.fc19,jsch-0.1.50-1.fc19,eclipse-4.3.0-0.45.git4bccf2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-05-14 13:47:50 EDT
Package icu4j-50.1.1-1.fc19, eclipse-4.3.0-0.46.git4bccf2.fc19, sat4j-2.3.4-1.fc19, jsch-0.1.50-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing icu4j-50.1.1-1.fc19 eclipse-4.3.0-0.46.git4bccf2.fc19 sat4j-2.3.4-1.fc19 jsch-0.1.50-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8126/icu4j-50.1.1-1.fc19,sat4j-2.3.4-1.fc19,jsch-0.1.50-1.fc19,eclipse-4.3.0-0.46.git4bccf2.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-05-24 16:22:35 EDT
icu4j-50.1.1-1.fc19, eclipse-4.3.0-0.46.git4bccf2.fc19, sat4j-2.3.4-1.fc19, jsch-0.1.50-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Gerard Ryan 2013-06-09 16:58:32 EDT
This is back again on rawhide. eclipse-4.3.0-0.61.git7bf397.fc20 at least, not sure about previous versions.

It seems to happen most often at weekends, when I have time to work on stuff, and when there's nobody around to fix it :P
Comment 10 Krzysztof Daniel 2013-06-13 09:10:21 EDT
Still broken?
Comment 11 Gerard Ryan 2013-06-15 15:39:42 EDT
(In reply to Krzysztof Daniel from comment #10)
> Still broken?

I just tried in mock with version 4.3.0-0.64.git84cba7, still appears broken (I guess you know that though, since you added other bugs since you asked the question. I look forward to this being fixed :)
Comment 12 Krzysztof Daniel 2013-06-17 07:29:53 EDT
I'm on it.
Comment 13 Krzysztof Daniel 2013-06-17 09:15:10 EDT
Important bits are:
!MESSAGE Unable to access file "plugins/org.glassfish.web.javax.servlet.jsp_2.2.6.jar!META-INF/MANIFEST.MF".
which in says that symlink is broken, which happened due to the glassfish-jsp.jar rename.
Comment 14 Krzysztof Daniel 2013-06-17 10:21:38 EDT
So, Gerard, this issue seems to be fixed now :-)

Wouldn't it be simpler to move to the tycho build?
Comment 15 Gerard Ryan 2013-08-17 13:33:49 EDT
(In reply to Krzysztof Daniel from comment #14)
> So, Gerard, this issue seems to be fixed now :-)
> 
> Wouldn't it be simpler to move to the tycho build?

It's happening again! :)
http://koji.fedoraproject.org/koji/taskinfo?taskID=5824649

I agree that tycho would be easier, but it seems that not all projects are using it yet :-/
Comment 16 Alexander Kurtakov 2013-08-20 03:15:15 EDT
Gerard,
Please try eclipse-4.3.0-11.fc20 , whenever a dependency changes we need to rebuild in order to get p2 metadata regenerated.
Comment 17 Gerard Ryan 2013-08-22 14:08:15 EDT
(In reply to Alexander Kurtakov from comment #16)
> Gerard,
> Please try eclipse-4.3.0-11.fc20 , whenever a dependency changes we need to
> rebuild in order to get p2 metadata regenerated.

That works great, thanks for the fix! :)

Since most of the time that I have to work on Fedora stuff is at the weekends, that's when I run into these problems, and both you and Krzysztof would be online less. Would it be okay in those situations for me to find a provenpackager to kick off a rebuild in rawhide, rather than having to wait until the following week when you guys are around?
Comment 18 Gerard Ryan 2013-08-22 15:12:05 EDT
(In reply to Gerard Ryan from comment #17)
> Since most of the time that I have to work on Fedora stuff is at the
> weekends, that's when I run into these problems, and both you and Krzysztof
> would be online less.

Or late in the evenings like right now, and it turns out that it needs to be rebuilt now, because of new jetty in rawhide today ;D
Comment 19 Roland Grunberg 2013-08-22 16:31:52 EDT
I've pushed a rebuild here for now : http://koji.fedoraproject.org/koji/taskinfo?taskID=5843348 .
Comment 20 Gerard Ryan 2013-08-24 07:49:16 EDT
Thanks Roland! I'll re-close this.
Comment 21 Gerard Ryan 2013-08-24 16:32:57 EDT
I was wrong, this is still a problem. The regeneration of p2 metadata from the rebuild has fixed building with tycho, but building with pdebuild is still an issue.

Comment #13 gave me an idea to check if any symlinks were broken and it turns out there are two. I've opened bug #1000740 for that.
Comment 22 Gerard Ryan 2013-08-29 19:58:12 EDT
Working again, thanks.

Note You need to log in before you can comment on or make changes to this bug.